480FS F-16 package not showing

All things Military AI that don't fit anywhere else.
User avatar
John Young
MAIW Developer
MAIW Developer
Posts: 3398
Joined: 12 Jul 2008, 15:15

Re: 480FS F-16 package not showing

Post by John Young »

No, you said FSX models can be used in early versions of P3D,which implies not in the later versions.

That got me thinking again. I've been assuming that my FSX native models do work in all versions of P3D. I know they work in V4 but I don't have V5 so I have to rely on users telling me if there are any problems. No one has done that. If there is an incompatibility, I will have to think seriously about what I am designing for with 5 FS versions on the go. As you say, a lot of the FSX user base might now have fled, but so long as I can kill 3 birds with one stone (FSX, P3Dv4 and P3Dv5) I'm not too concerned.

John
User avatar
hschuit
MAIW Developer
MAIW Developer
Posts: 526
Joined: 20 Jul 2011, 07:25
Version: P3D
Location: Near EHSB

Re: 480FS F-16 package not showing

Post by hschuit »

FSX Acceleration sdk models can be used in ALL P3D versions incl. v5.1. If you want maximum compatibility, FSX sdk is the way to go. Only if you need special P3D features like lua scripting (introduced with the P3Dv2 sdk) or PBR (introduced with P3Dv4.4) you have to use a P3D sdk. P3D sdk models are incompatible with older P3D versions and FSX.
User avatar
John Young
MAIW Developer
MAIW Developer
Posts: 3398
Joined: 12 Jul 2008, 15:15

Re: 480FS F-16 package not showing

Post by John Young »

Thanks Henk. It's what I thought.

John
User avatar
Firebird
MAIW Admin
MAIW Admin
Posts: 10907
Joined: 11 Aug 2006, 21:04
Version: FS9
Location: EGLL

Re: 480FS F-16 package not showing

Post by Firebird »

Appreciate the clarification, John. I was under the impression that FSX models were not completely compatible with v4+ but I have amended my mental note.

The root cause here though, I think, is still that FSX and P3D are being linked together. It would be better if any model was only tagged with the system it was compiled for.

I realise that this would only up the question about whether this version works in that sim. To be honest guys, what is wrong with trying it out. It doesn't cost you anything.
Steve
_______________________________________________________
Image
Quid Si Coelum Ruat
_______________________________________________________

Champions of Europe
User avatar
f4nutter
MAIW Developer
MAIW Developer
Posts: 2055
Joined: 01 Nov 2007, 16:00
Version: P3D
Location: EGDC
Contact:

Re: 480FS F-16 package not showing

Post by f4nutter »

I think its best in future ventures that they will only be for P3Dv4, I cant see or test them for FS9 or FSX :cry:
User avatar
John Young
MAIW Developer
MAIW Developer
Posts: 3398
Joined: 12 Jul 2008, 15:15

Re: 480FS F-16 package not showing

Post by John Young »

Tagging the models with the intended sim version wouldn't have helped in this case Steve, because the fundamental problem had not been recognised - that the supplied P3D models were not compatible with FSX.

John
User avatar
Greg
MAIW Admin
MAIW Admin
Posts: 3906
Joined: 12 Aug 2006, 19:56
Version: P3D
Location: Belgium

Re: 480FS F-16 package not showing

Post by Greg »

John Young wrote: 09 Jun 2021, 12:00I have to rely on users telling me if there are any problems. No one has done that.
Allow me to jog your memory. :wink:

https://militaryaiworks.com/forums/83/1 ... 99#p198499
User avatar
John Young
MAIW Developer
MAIW Developer
Posts: 3398
Joined: 12 Jul 2008, 15:15

Re: 480FS F-16 package not showing

Post by John Young »

So, having re-read the posts in your link Greg, three issues were flagged - prop discs against the sky - then fixed by LM and afterburners not displaying correctly. Since the test of the latter was in my F-15E that used an aircraft.cfg light source rather than an embedded effect, that was to be expected. I'm assuming that embedded effects, that I now use, are fine, as they are in P3Dv4.

There was also mention of the sound_ai folder in the F-15E, but that's not an essential component and something I hardly ever provide because I don't know how to create sound files and configurations for AI. That folder was donated by someone else.

I will continue to assume that my FSX native models work in P3Dv5. If they don't and we can't yet develop AI for FS2020, then I have to ask if it's worth continuing with this hobby. It's just getting more and more complicated knowing what to design for.

With FS9 demand so low and FSX probably going the same way, maybe as Ray says, it's just P3Dv4. Since I don't really like the graphics, that's not an incentive for me.

John
User avatar
gsnde
MAIW Staff
MAIW Staff
Posts: 3839
Joined: 05 Apr 2007, 08:13
Version: P3D
Location: South-West Germany
Contact:

Re: 480FS F-16 package not showing

Post by gsnde »

Aside from some effect thingies I can’t remember having any issues with FSX aircraft in P3Dv5. Which has been updated to 5.2 an hour ago.

Maybe you should have a look at the version, John. I am very happy with v5. The new version claims to have fixed most of what had been reported plus add a bunch of new features.
Cheers,
Martin
________________________________________
The Owl's Nest * Military Aircraft Reference * ICAO Reference * Distance Calculator * MAIW, Military AI & UKMil Reference
User avatar
John Young
MAIW Developer
MAIW Developer
Posts: 3398
Joined: 12 Jul 2008, 15:15

Re: 480FS F-16 package not showing

Post by John Young »

Do I have to pay again when upgrading from 4.5 to 5.2? I've just spent 10 minutes on the LM website but I'm none the wiser.

John
Joseph29
Colonel
Colonel
Posts: 2023
Joined: 20 Sep 2006, 20:35
Version: P3D
Location: Long Island New York

Re: 480FS F-16 package not showing

Post by Joseph29 »

John Young wrote: 09 Jun 2021, 21:10 Do I have to pay again when upgrading from 4.5 to 5.2? I've just spent 10 minutes on the LM website but I'm none the wiser.

John
If you are moving from P3D v4.5 to v5.2 then you will have to pay again. If you were moving from v5.1 to v5.2 then it would be free.
dummy
Second Lieutenant
Second Lieutenant
Posts: 82
Joined: 11 Jan 2018, 10:38
Version: FSX
Location: near EHKD

Re: 480FS F-16 package not showing

Post by dummy »

Hi guys,

never thought this question would end up in such a long discussion :shock:
I'm not very familiar with all the different SDK's and their limitations but if i read the thread correctly i can conclude that the package was not designed for FSX and therfore will not work? Correct me if i'm wrong.

@ You said that after you ran the aircraft through MCX the aircraft would show up in FSX. Is that something a noob like me can do easily? :lol:

But thanks again to you all for helping me find the cause of this mystery.

Best regards,

Edwin
User avatar
petebramley
MAIW Developer
MAIW Developer
Posts: 1409
Joined: 17 Jun 2007, 16:05
Version: P3D
Location: EGBG

Re: 480FS F-16 package not showing

Post by petebramley »

Hi Edwin

As its FSX you are using why not use the FS9 models that have been released for the Block 50's as mentioned in the readme aircraft.txt, As FSX retains backward compatibility with FS9 those models shoud work just fine. It was only with the release of P3Dv4 that backward compatibility was broken.

Regards
Pete B
Retired and busier than ever !!
User avatar
John Young
MAIW Developer
MAIW Developer
Posts: 3398
Joined: 12 Jul 2008, 15:15

Re: 480FS F-16 package not showing

Post by John Young »

I thought the same thing Pete, but I didn't see the FS9 F-16s when I tried them at Spangdahlem in FSX. I didn't spend much time on it and it might just need some simple tweaking.

Edwin, I found it a simple task to run the P3D F-16 2 seater through MCX and save it as an FSX file. It appeared just fine at Spangdahlem in FSX, but I didn't go so far as to observe a take-off and landing to see if all the animation was working properly.

I think I will bite the bullet and pay for P3Dv5.2 That might give me the ability to test in every sim I design for, if I can install P3Dv5.2 on the same hard drive as my current P3Dv4.5? Is that possible please?

John
User avatar
hschuit
MAIW Developer
MAIW Developer
Posts: 526
Joined: 20 Jul 2011, 07:25
Version: P3D
Location: Near EHSB

Re: 480FS F-16 package not showing

Post by hschuit »

John, you can install multiple P3D versions, they will be strictly separated, each one has different app and user settings folder locations. This is also true for the different SDK versions but I only use the latest (5.2) which still allows me to export models in the various P3D formats (P3DV2, V4, V44).
User avatar
John Young
MAIW Developer
MAIW Developer
Posts: 3398
Joined: 12 Jul 2008, 15:15

Re: 480FS F-16 package not showing

Post by John Young »

Excellent. Thanks Henk.

John
dummy
Second Lieutenant
Second Lieutenant
Posts: 82
Joined: 11 Jan 2018, 10:38
Version: FSX
Location: near EHKD

Re: 480FS F-16 package not showing

Post by dummy »

petebramley wrote: 10 Jun 2021, 13:24 Hi Edwin

As its FSX you are using why not use the FS9 models that have been released for the Block 50's as mentioned in the readme aircraft.txt, As FSX retains backward compatibility with FS9 those models shoud work just fine. It was only with the release of P3Dv4 that backward compatibility was broken.

Regards
Hi Pete,

thank you for your suggestion, never thought of it myself :oops: :D .
I installed the FS9 version and they are showing. :smt023 I only wonder if the converted P3D version will give better performance.

Edwin
User avatar
petebramley
MAIW Developer
MAIW Developer
Posts: 1409
Joined: 17 Jun 2007, 16:05
Version: P3D
Location: EGBG

Re: 480FS F-16 package not showing

Post by petebramley »

Glad you got it sorted. A model compiled for FSX might give slightly better performance but with the FS9 version working in FSX there may not be the enthusiasm to create it.
Pete B
Retired and busier than ever !!
Post Reply