NAS Kingsville package by MAIW

Post all questions and problems with official MAIW Packages for FS9 in this forum. Each package has a dedicated thread for support.
User avatar
Flyin Illini
Major
Major
Posts: 686
Joined: 14 Aug 2008, 10:42
Version: FS9

Post by Flyin Illini »

No the issue is basically anything that climbs up past 8500 disappears or anything that decends below 8500 reappears. its weird, isnt AI supposed to do the whole flight, its like a barrier there that doesnt allow AI to fly through it, that is my issue. Anything doing pattern work or anything just below 8500ftAGL is visable, anything above that is gone. TVb didnt help either, they still disappeared above 8500, is there a FS9 cfg file that sets a visible AI altitude?

User avatar
MIKE JG
MAIW Developer
MAIW Developer
Posts: 10734
Joined: 12 Aug 2006, 02:25
Version: FS9

Post by MIKE JG »

An AI "No Fly Zone" maybe............ :D
-Mike G.

User avatar
MIKE JG
MAIW Developer
MAIW Developer
Posts: 10734
Joined: 12 Aug 2006, 02:25
Version: FS9

Post by MIKE JG »

Seriously though, it almost sounds like you have invisible terrain mesh or something odd like that. Have you flown along with an AI aircraft in formation? If so, does your flyable aircraft disappear as well?
-Mike G.

User avatar
Flyin Illini
Major
Major
Posts: 686
Joined: 14 Aug 2008, 10:42
Version: FS9

Post by Flyin Illini »

yes ive flown in formation them and as they hit that barrier they are gone and i can keep going.

User avatar
Flyin Illini
Major
Major
Posts: 686
Joined: 14 Aug 2008, 10:42
Version: FS9

Post by Flyin Illini »

hey, its not a problem with packages. The problem seems to be just the airplanes disappear 10 miles from the aiport starting location. Is there a way to basically set the world as the starting point so AI wont disappear? This seems to be what the whole problem was.

Ford Friendly
Lieutenant Colonel
Lieutenant Colonel
Posts: 823
Joined: 08 Jul 2007, 22:15
Version: FS9

Post by Ford Friendly »

Flyin Illini wrote:hey, its not a problem with packages. The problem seems to be just the airplanes disappear 10 miles from the aiport starting location. Is there a way to basically set the world as the starting point so AI wont disappear? This seems to be what the whole problem was.
The key is in your first sentence there - it's not a package problem. This is the way MSFS version whatever works. Out past 10 miles away fro YOU - not from the starting airport - no aircraft are visible. It's a hard coded thing with no work around.

The reason that it works this way is because otherwise, the cpu/gpu load of rendering all traffic in a place like JFK/NYC or the KLAX/Los Angeles where there are multiple airports and high numbers of aircraft operating would be unacceptable. Think <3 FPS and scenery stutters, etc.

At least that's my understanding.

User avatar
MIKE JG
MAIW Developer
MAIW Developer
Posts: 10734
Joined: 12 Aug 2006, 02:25
Version: FS9

Post by MIKE JG »

The question is, when you say you are flying in formation with the AI, are you actually in a user aircraft and you are flying along with them, and they are still disappearing?

Ford IIRC, that's what is happening to him which doesn't make any logical sense.

Illini, what if any traffic programs are you using to follow/watch the AI traffic?
-Mike G.

User avatar
Flyin Illini
Major
Major
Posts: 686
Joined: 14 Aug 2008, 10:42
Version: FS9

Post by Flyin Illini »

Ok let me change what i said....
When im sitting at the airport yes they do disappear 10 miles way. I know that. Thats normal. But when i fly with them, they disappear after 10 miles from what is the starting location. Like ill fly say about .2 from one after it took off...soon as it hits the 10 mile barrier, it disappears, even when im flying right next to it. Its weird, it happens on arrivals too. Say im sitting in slew 10 miles out. say a southwest 737 just appears into its approach sequence. What i want to be able to do is fly with certain aircraft for their entire flights. Like this package. Theyve done the same.

User avatar
MIKE JG
MAIW Developer
MAIW Developer
Posts: 10734
Joined: 12 Aug 2006, 02:25
Version: FS9

Post by MIKE JG »

You should be able to fly entire flights with any AI aircraft. I've done it many times. If you are flying right next to them in a user aircraft, they should not disappear on you.

Honestly that's really weird as I've never heard of this happening to anyone else. Unfortunately that means that it might be something that we never get sorted out.

I just looked at my FS9.CFG file and I can't see any setting in there that might be related to this.

I know it's a drastic measure but you could try a complete re-install of FS9. It's a lot of work but sometimes it's the only way to rid yourself of these pesky issues.
-Mike G.

User avatar
Flyin Illini
Major
Major
Posts: 686
Joined: 14 Aug 2008, 10:42
Version: FS9

Post by Flyin Illini »

Thanks for all the help guys, i appreciate, keep up the great work!

User avatar
Firebird
MAIW Admin
MAIW Admin
Posts: 10222
Joined: 11 Aug 2006, 21:04
Version: FS9
Location: EGLL

Post by Firebird »

The only thing that I have heard of in this instant, and I think I have my facts right is that the aircraft is en route to a place that doesn't exist.

Magic uses these type of points in his formation setups, you can add a point to the airports.txt file and within a certain point of its base it will quite happily fly there however for points outside a small range you have to have an afcad for the aircraft to continue.
I believe if there is no afcad, the plane starts its journey, will reach a certain distance and then disappear to reappear at the destination at the prescribed time. I think I have that right.

Is this what is happening here?
Steve
_______________________________________________________
Image
Quid Si Coelum Ruat
_______________________________________________________

User avatar
Flyin Illini
Major
Major
Posts: 686
Joined: 14 Aug 2008, 10:42
Version: FS9

Post by Flyin Illini »

ok i have one last possible assumption, i took out some of my default Airlines like the 747, 737 etc. You think that coupl possibly be disrupting them?

User avatar
Firebird
MAIW Admin
MAIW Admin
Posts: 10222
Joined: 11 Aug 2006, 21:04
Version: FS9
Location: EGLL

Post by Firebird »

In a word no, if there was was a problem to do with a deleted aircraft your planes wouldn't show up at all.

Did you check up on what I was suggesting? Where is it that the planes are going to and from. The only reason I am aware of for planes disappearing after 10 miles is that its destination only exists as entry in the airports.txt file that was used to create that particular bgl.

Are these AI flights ones that you have made yourself? If so would you be willing to attach the raw text files here so that we can see if there are simple errors.
Also if you are able to give us the exact time, flight number and departure airfield of a problem aircraft, from an MAIW package, then we can put that under the microscope.
Steve
_______________________________________________________
Image
Quid Si Coelum Ruat
_______________________________________________________

User avatar
Flyin Illini
Major
Major
Posts: 686
Joined: 14 Aug 2008, 10:42
Version: FS9

Post by Flyin Illini »

Ok here is everything i have tried:

Tried:
Traffic toolbox, now uninstalled
TVB, on and off,
updated scenery indexs
flew miles back, flew close to them still disappears
uninstalled FSUIPC, installed FSUIPC,
--Followed around as many as i can from both WOAI, MAIW-all do the same disappear at 10NM no matter what, even with TVB, the airplane must be 10nm or less from their destination to view under altitude.
My tags are carolina blue if that means anything--bout 100% sure it doesnt

Interests:

I have followed several groups for several miles under that barrier, i followed two F-15s from the Florida ANG at KJAX for about 50 under 9000ft while they were doing pattern work. Same with the A-10 screenshots i posted.

These files are not any of mine. Although the ones i made for Scott AFB do it to. Disappear after a certain altitude.

The only thing i havent done is a clean install and thats at a EXETREME last resort.

User avatar
BadPvtDan
MAIW Admin
MAIW Admin
Posts: 3786
Joined: 11 Aug 2006, 21:14
Version: FSX
Location: Round Rock, TX
Contact:

Post by BadPvtDan »

You may be there mate. I've never seen this problem. I alwYs find a reinstall invigorating. It let's me clean up some of the messes I created.
"The first rule of Zombieland: Cardio. When the zombie outbreak first hit, the first to go, for obvious reasons... were the fatties."

User avatar
MIKE JG
MAIW Developer
MAIW Developer
Posts: 10734
Joined: 12 Aug 2006, 02:25
Version: FS9

Post by MIKE JG »

BadPvtDan wrote:You may be there mate. I've never seen this problem. I alwYs find a reinstall invigorating. It let's me clean up some of the messes I created.
I find them to be giant pains in the you know what. :D BUT, sometimes it's your only option.
-Mike G.

User avatar
Flyin Illini
Major
Major
Posts: 686
Joined: 14 Aug 2008, 10:42
Version: FS9

Post by Flyin Illini »

well i guess it was caused by my FS being messed up. I cant even uninstall it because the uninstall disappeared. So i dont know how to remove it :(.

User avatar
MIKE JG
MAIW Developer
MAIW Developer
Posts: 10734
Joined: 12 Aug 2006, 02:25
Version: FS9

Post by MIKE JG »

Did you try through the Windows Start menu/Add-Remove Programs feature?
-Mike G.

Blank Fang
MAIW Veteran
MAIW Veteran
Posts: 449
Joined: 29 Aug 2006, 16:32
Version: FS9
Location: LSZH

Post by Blank Fang »

Simply insert the #1 FS9 Setup CD and you will be offered the uninstall option.
Good Luck
Willy

User avatar
Flyin Illini
Major
Major
Posts: 686
Joined: 14 Aug 2008, 10:42
Version: FS9

Post by Flyin Illini »

I had to do it the hard way, go through and take out all possible FS related items including registry keys. It was a rough time but it is reinstalled, just putting back in all my old files and ill be checking on it soon to see if its back to normal or not. If not im giving up on flying with AI.

Post Reply