P3Dv4 packages in FSX

All things Military AI that don't fit anywhere else.
Post Reply
ttocs
Cadet
Cadet
Posts: 1
Joined: 13 Sep 2015, 20:39
Version: FSX

P3Dv4 packages in FSX

Post by ttocs »

I see packages listed for "FSX and P3Dv4". Can a P3Dv4 package work in FSX? For example there is "Iwakuni_2018_P3Dv4", will it also work for FSX.

User avatar
Firebird
MAIW Admin
MAIW Admin
Posts: 10709
Joined: 11 Aug 2006, 21:04
Version: FS9
Location: EGLL

Re: P3Dv4 packages in FSX

Post by Firebird »

I think, and I am willing to be corrected here, that FSX packages can be used in P3D up to v4. There may need to be some mod work on scenery but the aircraft will work.
If a package is designated FSX/P3Dv4 then it is designed for FSX and is compatible with P3Dv4.
Steve
_______________________________________________________
Image
Quid Si Coelum Ruat
_______________________________________________________

User avatar
tango234
Major
Major
Posts: 678
Joined: 10 Feb 2009, 20:11
Version: P3D
Location: UK

Re: P3Dv4 packages in FSX

Post by tango234 »

It depends on what is in the package.

I have never attempted to use a P3dV4 native airport file in FSX though I suspect it would not work. Using ADE to open the airport file and export it as an FSX-native file is fairly straightforward I think, though you cannot use that method to convert landclass (CVX) files unless you have the base project files to hand (and they are not usually included in downloads). Never tried it though so I could well be utterly wrong.

.dds format textures work perfectly in both sims. So do FSX-native flightplans (which are also the standard for P3D).

P3Dv4-native models do not work in FSX, though looking at that package at first glance the models appear to be FSX native so would be fine. If not, there are FSX-compatible models around that the textures will fit on.

In short, in many cases you can make it work but it can require some elbow grease. Certainly, as Steve says if something is marked FSX/P3Dv4 in the download area it will be absolutely fine in FSX. If it is only marked P3Dv4 then it might need a little work.

User avatar
TimC340
Major
Major
Posts: 522
Joined: 07 Mar 2015, 13:18
Version: P3D
Location: Hadleigh, Suffolk

Re: P3Dv4 packages in FSX

Post by TimC340 »

ADE will object to opening a P3Dv4 (ADEP4) .ad4 file in FSX mode. However, the bgls may well work in FSX, depending on the models used.

User avatar
John Young
MAIW Developer
MAIW Developer
Posts: 3102
Joined: 12 Jul 2008, 15:15

Re: P3Dv4 packages in FSX

Post by John Young »

The problem might be the ground. It is compiled for P3Dv4 I think.

John

User avatar
petebramley
MAIW Developer
MAIW Developer
Posts: 1359
Joined: 17 Jun 2007, 16:05
Version: P3D
Location: EGBG

Re: P3Dv4 packages in FSX

Post by petebramley »

If the ADE is compiled with the P3Dv4 SDK then using it in FSX is most likely to crash the sim. There are new elements in P3D that FSX does not recognise and so throws a wobbly. Only way would be to de-compile the file and re-compile with the FSX SDK having stripped out all the P3D specific elements.
Pete B
Retired and busier than ever !!

Post Reply