FS9 stops running

Use this forum to discuss technical issues related to the operation of your computer. Graphics, Hardward, Software, settings, etc.
Post Reply
User avatar
Jive1
First Lieutenant
First Lieutenant
Posts: 130
Joined: 16 Jun 2010, 13:01
Version: FSX
Location: Belgium Antwerp EBAW
Contact:

FS9 stops running

Post by Jive1 »

Hey!
Good day to all.
My problem is rather extensively explained ijn the attachment
Please, is there anybody who could give me advise to help to find a solution so that FS9 does no longer stop after a while of flying.
Thanks.
Jive1 - Belgium
Windows 10 Home NLD 64bit Intel(R) Core(TM) i3-2120 CPU @ 3.30GHz 1600
NVIDIA GeForce GT 430 1024MB 1920 x 1080 NVIDIA High Definition Audio
C:\ NTFS 120,12GB 95,81GB 8 170MB
Redbull AV and Redbull Firewall

User avatar
Firebird
MAIW Admin
MAIW Admin
Posts: 10400
Joined: 11 Aug 2006, 21:04
Version: FS9
Location: EGLL

Re: FS9 stops running

Post by Firebird »

So but there was no attachment to view.
Steve
_______________________________________________________
Image
Quid Si Coelum Ruat
_______________________________________________________

User avatar
Jive1
First Lieutenant
First Lieutenant
Posts: 130
Joined: 16 Jun 2010, 13:01
Version: FSX
Location: Belgium Antwerp EBAW
Contact:

Re: FS9 stops running

Post by Jive1 »

Indeed, Firebird, there is no such an attachment, possibly due to the fact that the 'move and drop' do not work.
I moved a copy to my site, and you can download it from there http://www.jive1.be/document.pdf'
Greetz
Jive1 - Belgium
Windows 10 Home NLD 64bit Intel(R) Core(TM) i3-2120 CPU @ 3.30GHz 1600
NVIDIA GeForce GT 430 1024MB 1920 x 1080 NVIDIA High Definition Audio
C:\ NTFS 120,12GB 95,81GB 8 170MB
Redbull AV and Redbull Firewall

User avatar
gsnde
MAIW Staff
MAIW Staff
Posts: 3569
Joined: 05 Apr 2007, 08:13
Version: P3D
Location: South-West Germany
Contact:

Re: FS9 stops running

Post by gsnde »

Wasn't there something with a specific type of file (land class?) where there had to be (or not) a texture folder to prevent a memory leak?

From mobile hence short

Cheers,
Martin
________________________________________
ImageThe Owl's Nest * Military Aircraft Reference * ICAO Reference * Distance Calculator * MAIW, Military AI & UKMil Reference

User avatar
John Young
MAIW Developer
MAIW Developer
Posts: 2865
Joined: 12 Jul 2008, 15:15

Re: FS9 stops running

Post by John Young »

Is your new processor over-clocked? When my PC was delivered over-clocked, FS9 would stop after a short period of time flying. I had to reset the BIOS to normal clock speed for FS9 to stabilise. It's been fine since doing that.

John

User avatar
Firebird
MAIW Admin
MAIW Admin
Posts: 10400
Joined: 11 Aug 2006, 21:04
Version: FS9
Location: EGLL

Re: FS9 stops running

Post by Firebird »

Like John, I had a PC that was overclocked and it ran perfectly fine on everything BUT FS9.
I could recreate using the same scenario every time and the PC rebooted with monotonous regularity. I downgraded the clock on the CPU and no more crashes.

In short only FS9 crashed the PC when overclocked and that stopped when I set it back to default. I do not overclock any more because upping the CPU speed is not the only change you have to make and if you don't get everything in sync then it will crash.

Now if you are able to rule out overclocking then I will think some more.
Steve
_______________________________________________________
Image
Quid Si Coelum Ruat
_______________________________________________________

User avatar
gsnde
MAIW Staff
MAIW Staff
Posts: 3569
Joined: 05 Apr 2007, 08:13
Version: P3D
Location: South-West Germany
Contact:

Re: FS9 stops running

Post by gsnde »

Only if overclocking can be ruled out... I was right with that the issue I have described above is related to land class files. If you have a scenery with land class activated, it may not have an empty texture folder.
This would cause a memory leak which finally kills FS9.


From mobile hence short

Cheers,
Martin
________________________________________
ImageThe Owl's Nest * Military Aircraft Reference * ICAO Reference * Distance Calculator * MAIW, Military AI & UKMil Reference

plumber
Captain
Captain
Posts: 311
Joined: 12 May 2008, 11:02
Version: FS9
Location: Blackpool. UK

FS9 stops running

Post by plumber »

Error

User avatar
Jive1
First Lieutenant
First Lieutenant
Posts: 130
Joined: 16 Jun 2010, 13:01
Version: FSX
Location: Belgium Antwerp EBAW
Contact:

Re: FS9 stops running

Post by Jive1 »

Hey!
Good morning to all!
It is quiet possible that my CPU is overclocked, but how can I know that it is?
This is a completely new issue to me, I've never had to do something with the CPU of any of my previous computers, nor do I know how I even should try to determine whether it is or not.
I've been searching on Internet to find more information, but it seems very delicate to change anything if I don't know what exactly I should do to find out and, even if it is, to modify it to not overclocked.
Can somebody tell me more about this subject, please?
Furthermore, how can I find out that there might be something wrong with the 'landclass' files? At least there is apparenty nothing specific that shows about landckass files in the sceneries that I'm using till now. How to find out, if that would be the origin of the phenomenon, whether there is a wrong landclass file somewhere?
This is presently still too hot a coffee to me...
Jive1 - Belgium
Windows 10 Home NLD 64bit Intel(R) Core(TM) i3-2120 CPU @ 3.30GHz 1600
NVIDIA GeForce GT 430 1024MB 1920 x 1080 NVIDIA High Definition Audio
C:\ NTFS 120,12GB 95,81GB 8 170MB
Redbull AV and Redbull Firewall

User avatar
Jive1
First Lieutenant
First Lieutenant
Posts: 130
Joined: 16 Jun 2010, 13:01
Version: FSX
Location: Belgium Antwerp EBAW
Contact:

Re: FS9 stops running

Post by Jive1 »

Hey!
I'm here again....
When entering the BIOS of my new pc there is the possibility to boot default or to enter the Setup.
My question is here: if I boot default, would that result in a lower clock of my CPU? Because apparentlythe CPU is @3.30GHz, whereas the CPU has a normal speed of 3.000MHz, according to inside the BIOS data there is lentioned :
Target CPU / Cache / Blck speed 3000MHz : 3200MHz : 100.000 MHz
So, would it be better then when I satrt BIOS default?
Jive1 - Belgium
Windows 10 Home NLD 64bit Intel(R) Core(TM) i3-2120 CPU @ 3.30GHz 1600
NVIDIA GeForce GT 430 1024MB 1920 x 1080 NVIDIA High Definition Audio
C:\ NTFS 120,12GB 95,81GB 8 170MB
Redbull AV and Redbull Firewall

User avatar
Jive1
First Lieutenant
First Lieutenant
Posts: 130
Joined: 16 Jun 2010, 13:01
Version: FSX
Location: Belgium Antwerp EBAW
Contact:

Re: FS9 stops running

Post by Jive1 »

Hey!
I have another question before I dare to boot default: if I boot default and that seems not to be good, can I then go back to the siuation that was before booting default? If that is possible, then as a test booting default would be interesting to try....
Jive1 - Belgium
Windows 10 Home NLD 64bit Intel(R) Core(TM) i3-2120 CPU @ 3.30GHz 1600
NVIDIA GeForce GT 430 1024MB 1920 x 1080 NVIDIA High Definition Audio
C:\ NTFS 120,12GB 95,81GB 8 170MB
Redbull AV and Redbull Firewall

User avatar
gsnde
MAIW Staff
MAIW Staff
Posts: 3569
Joined: 05 Apr 2007, 08:13
Version: P3D
Location: South-West Germany
Contact:

FS9 stops running

Post by gsnde »

There is no such thing as last configuration in the BIOS, Jive. But you could write down (or take a picture with your mobile) of the various settings and manually restore them if you are not happy with the result.

Resetting a BIOS to the default values is for example recommended after every BIOS update to make sure no old settings can interfere with a new version.

So setting a BIOS to default basically means you going for the most safe, least aggressive settings. And that is what you are looking for right now.
Cheers,
Martin
________________________________________
ImageThe Owl's Nest * Military Aircraft Reference * ICAO Reference * Distance Calculator * MAIW, Military AI & UKMil Reference

User avatar
Jive1
First Lieutenant
First Lieutenant
Posts: 130
Joined: 16 Jun 2010, 13:01
Version: FSX
Location: Belgium Antwerp EBAW
Contact:

Re: FS9 stops running

Post by Jive1 »

Hey!
It did not help...
When starting at default BIOS, I have exactly the saBame result! After approx. 10 minutes of flight, and when Memory use was 1528MB, according to Task Manager, FS9 stopped, telling that my computer had run out of available memory, and flight simulator will exit, because there might not be enough free space on my hard disk, that I must clean up that drive and start FS9 again.
But my harddisk is almost empty, it is new, there is 470GB free space of 500...
I'm very unhappy now... What could then be the origin of tha error?
Jive1 - Belgium
Windows 10 Home NLD 64bit Intel(R) Core(TM) i3-2120 CPU @ 3.30GHz 1600
NVIDIA GeForce GT 430 1024MB 1920 x 1080 NVIDIA High Definition Audio
C:\ NTFS 120,12GB 95,81GB 8 170MB
Redbull AV and Redbull Firewall

User avatar
Firebird
MAIW Admin
MAIW Admin
Posts: 10400
Joined: 11 Aug 2006, 21:04
Version: FS9
Location: EGLL

Re: FS9 stops running

Post by Firebird »

Ahhh OK. That is a big clue the problem is that you have not got enough virtual memory set aside on your PC. It is that memory that has run out not your RAM.

How much RAM do you have on your system?
What you should do is set your virtual memory to at least 150% of that, unless you have a phenominal amount of RAM.. I would also make sure that it is all in one piece, not set up across more than one disk or partition. Also make sure that it is set up on your fastest drive so if you have an SSD make sure that it is on that drive.

To give you an example my PC has 16GB of memory and the virtual memory is managed by the OS, on my SSD, and is currently 16GB in size.
You might think that your FS would use all RAM before going on to virtual memory but you would be wrong. FS was designed in the days that the amount of RAM in a PC could be very low. If you look at the original FS9 case you will see that it recommends 128mb of RAM.
So it was designed to page data in and out of RAM to virtual memory.
Steve
_______________________________________________________
Image
Quid Si Coelum Ruat
_______________________________________________________

User avatar
Jive1
First Lieutenant
First Lieutenant
Posts: 130
Joined: 16 Jun 2010, 13:01
Version: FSX
Location: Belgium Antwerp EBAW
Contact:

Re: FS9 stops running

Post by Jive1 »

Hey!
Good morning to all!

I'm happy to say that my problem is solved! It was not something with my PC and it's specifications, but it was a question of right positioning of the LC-files.

Earlier, I told that I had only a few sceneries installed, amongst them both Waters and Roads of Taburet. Well, these Taburet files are in fact LC files, and they were on the wrong position of the active files in Addon list.

You see, I use to have all the sceneries of one country in one single Addon folder, and that in se works fine, and.. it gives me less Addon folders than when I use a seperate folder for each separate scenery.

Now, for Belgium, The Netherlands and Luxembourg, I have only one Addon Folder, because they are three smaller countries, and also, because Taburet made also one single folder for Roads and Waterd of these three smaller countries.
I had his files at the lowest position inside the Benelux ( = Belgium + The Netherlands + Luxembourg ) Addon Folder, and that was wrong. I did the same whit myu old computer, but for one or other reason it was not so bad in that times. When I placed these Roads and Waters files in the BASE scenery, everything became OK. No more memory drop, and the consumption of memory, according to the data of my Task Manager was only ca. 500Mb, and it remained around 500 Mb instead of increasing up to 1500 Mb.

From now on I will keep all the LandClass files and also all WaterClass files down under in the Base folder of Sceneries.

And this brings me to a minor question: some scenery makers, like Aerosoft, put some LC-files in the zipped folder of a scenery; is it better to take these out of thatscenery folder, and put them down under in the Base folder of the Sceneries, or should they remain in the unzipped scenery addon folder?

On the other hand, I think that this determination here might be interesting for other pilots too...

Greetz
Jive1 - Belgium
Windows 10 Home NLD 64bit Intel(R) Core(TM) i3-2120 CPU @ 3.30GHz 1600
NVIDIA GeForce GT 430 1024MB 1920 x 1080 NVIDIA High Definition Audio
C:\ NTFS 120,12GB 95,81GB 8 170MB
Redbull AV and Redbull Firewall

User avatar
Jive1
First Lieutenant
First Lieutenant
Posts: 130
Joined: 16 Jun 2010, 13:01
Version: FSX
Location: Belgium Antwerp EBAW
Contact:

Re: FS9 stops running

Post by Jive1 »

I forgot to tell: my RAM is 16 Gb....
Jive1 - Belgium
Windows 10 Home NLD 64bit Intel(R) Core(TM) i3-2120 CPU @ 3.30GHz 1600
NVIDIA GeForce GT 430 1024MB 1920 x 1080 NVIDIA High Definition Audio
C:\ NTFS 120,12GB 95,81GB 8 170MB
Redbull AV and Redbull Firewall

User avatar
Firebird
MAIW Admin
MAIW Admin
Posts: 10400
Joined: 11 Aug 2006, 21:04
Version: FS9
Location: EGLL

Re: FS9 stops running

Post by Firebird »

Firstly, glad that you got it sorted.

On the question on LC files you can leave them where they are, providing that the the scenery folder that they are in does not have an empty texture folder there as well. If it has a texture folder that is not empty it is fine.

If you are in any doubt and you want to move them but you want to remember where the were originally then this is a tip that I use myself.
I copy the LC file into my special Landclass folder that I have activated. I also have a txt file in there where I list where all the LC files and the scenery that they were installed with. For added safety, I then create an 'Archive' folder in the original locations 'Scenery' folder and then move the LC file there.

This way if anything gets uninstalled I have two ways of catching that there is a LC file that needs to be removed as well.

Finally check your systems virtual memory set up anyway. Just to make sure that it is set up correctly.
Steve
_______________________________________________________
Image
Quid Si Coelum Ruat
_______________________________________________________

User avatar
Jive1
First Lieutenant
First Lieutenant
Posts: 130
Joined: 16 Jun 2010, 13:01
Version: FSX
Location: Belgium Antwerp EBAW
Contact:

Re: FS9 stops running

Post by Jive1 »

Hey! Firebird,
Ok, I did like you said: my Virtual memory is set now on the SSD drive C:\ and it is 6GB.
I will wait and see as from now wether everything runs well, en eventually later on invrease that v.m. if necessary.
Thank you for all your advise. Same thanks to all MAIW members who helped me with their advises.
Jive1 - Belgium
Windows 10 Home NLD 64bit Intel(R) Core(TM) i3-2120 CPU @ 3.30GHz 1600
NVIDIA GeForce GT 430 1024MB 1920 x 1080 NVIDIA High Definition Audio
C:\ NTFS 120,12GB 95,81GB 8 170MB
Redbull AV and Redbull Firewall

Post Reply