FS9 and WIN7 problem

Use this forum to discuss technical issues related to the operation of your computer. Graphics, Hardward, Software, settings, etc.
Post Reply
User avatar
bismarck
MAIW Developer
MAIW Developer
Posts: 2464
Joined: 04 Jan 2007, 14:35
Version: FS9
Location: Milan,Italy

FS9 and WIN7 problem

Post by bismarck » 24 Jun 2019, 19:14

I've become crazy for an entire week, but at least, I've found a workaround. :roll:
The background.
I usually reinstall completely my PC, every 4-5 years for various reasons, for example a lot of process starting without knowing from where they come from, and so on. Right or wrong, that's it.
I was thinking to reinstall my laptop from some month, when a couple of weeks ago, I noticed that FS9 was extremely slow and sometime it caused the crash of the PC.
Opening the Task Manager, all 4 cores were at 100% of CPU usage. Usually, just one is at 100%, other around 1- 2 % depending on what open.
This led me to rebuild the PC from scratch.
Once finished to reinstall Win7 and FS9, I had the same problem... :cry:
Having some doubts about what done, I did it again, another couple of time. Same problem. :evil:
I than checked the installation (almost never used) on my work-PC. Same problem! :evil: :evil:
Tried my home-desktop. Last time I've run FS on that PC, was at least two years ago. Same problem. :evil: :evil: :evil:

I thought at that fu...ng update of Windows that sometime causes strange problems.
Again I reinstalled Win7, blocked the update, install FS9 and..... SAME PROBLEM!!!! ( :evil: x 10)
The workaround.
Launch FS9. It doesn't start. You can see an FS9.EXE *32 in the Process Tab of the Task Manager. It uses 4-5 Kb of memory but nothing happen.
Launch again FS9, a second FS9.EXE *32 starts, and FS start-up screen appears. Contemporary with the second FS9.EXE *32, also starts Rundll32.exe using about 45Kb of memory. At this point, the four cores are at 100% of CPU usage.
Killing this last process, also the first FS9.EXE *32 closes, the cores come-back to normal operation and I finally can use FS9.
Someone else has notice the same problem?
Regards, Giorgio.
Image

User avatar
Firebird
MAIW Admin
MAIW Admin
Posts: 12109
Joined: 11 Aug 2006, 21:04
Version: FS9
Location: EGLL

Re: FS9 and WIN7 problem

Post by Firebird » 24 Jun 2019, 21:15

You said that you re-installed FS9.
Was this from a backup or from the CDs?

The reason that I am asking is that the first time you run FS9 it creates files in the background the first time that you create a flight and exit cleanly.

What i am wondering is whether you need to install from scratch, create a flight lift off and land straight away then clean exit. Then update to FS9.1 and do the same. Then you can makes sure you have the correct No CD patch in place.
Only then can you re-install a backup over the top, including the files stored in the system settings folder.

I am guessing here but I think that the system is looking for files that have not been setup yet or parameters not set up.
Steve
_______________________________________________________
Image
Quid Si Coelum Ruat
_______________________________________________________

User avatar
bismarck
MAIW Developer
MAIW Developer
Posts: 2464
Joined: 04 Jan 2007, 14:35
Version: FS9
Location: Milan,Italy

Re: FS9 and WIN7 problem

Post by bismarck » 25 Jun 2019, 07:04

No Steve, I've re-installed all from scratch, also Win7, formatting the partition I had before.
I have an Image (.ISO) of FS9 and I don't think to have the wrong CD Patch. It has worked for ages on this three PC and other PC I don't have anymore.

Thanks, Giorgio
Image

JohnTenn
Major
Major
Posts: 603
Joined: 12 Dec 2011, 17:16
Version: FS9

Re: FS9 and WIN7 problem

Post by JohnTenn » 25 Jun 2019, 07:36

Giorgio

This sounds horribly similar to the problem I had this last week.
A clean install of FS9 barely loaded and was very slow.

CPU usage at 100% or close to it.
Rundll32.exe using most of the processing power.

I took it to a professional whom I have got to know well over the last seven years.
He attaches an external source to check for viruses.

I asked him to check for viruses. Also suspected a trojan in Rundll32.
After checking the motherboard and CPU, these turned out to be the problem. Degraded circuitry.

Perhaps my circumstance is coincidental.

Does a clean install with no addons work on your computers?

John

User avatar
Firebird
MAIW Admin
MAIW Admin
Posts: 12109
Joined: 11 Aug 2006, 21:04
Version: FS9
Location: EGLL

Re: FS9 and WIN7 problem

Post by Firebird » 25 Jun 2019, 07:57

I am tempted to ask why you haven't upgraded to 10 but I am guessing that you have your reasons. Is it the age of your PC?

There was a lot of confusion in the early days about FS9 not working on 10 but this was inaccurate. It works perfectly fine in both windows and full screen modes.

I am struggling to think of anything that I had that didn't work on upgrading to 10, other than Gettysburg. Mostly its games that use the MS CDRom security system which has since been disabled by MS.
Steve
_______________________________________________________
Image
Quid Si Coelum Ruat
_______________________________________________________

User avatar
bismarck
MAIW Developer
MAIW Developer
Posts: 2464
Joined: 04 Jan 2007, 14:35
Version: FS9
Location: Milan,Italy

Re: FS9 and WIN7 problem

Post by bismarck » 25 Jun 2019, 10:06

Viruses are one of the reason that led me to re-install everything every 4-5 years.

"After checking the motherboard and CPU, these turned out to be the problem. Degraded circuitry."
It is hard to be believe that three different PC have the same problem at the same time, even if, at least two of them, are very old.

"Does a clean install with no addons work on your computers?"
No addon added for the test described. Just tested when FS9 installation finished.

"I am tempted to ask why you haven't upgraded to 10 but I am guessing that you have your reasons. Is it the age of your PC?"
The age of the PC is the main reason, plus other.

I'm still investigating with the help of mine colleagues. Hope to find something useful.

Thanks, Giorgio
Image

Post Reply