FS9 troubleshooting with Procmon

Use this forum to discuss technical issues related to the operation of your computer. Graphics, Hardward, Software, settings, etc.
Post Reply
jgowing
First Lieutenant
First Lieutenant
Posts: 124
Joined: 08 Oct 2008, 12:36
Version: FS9
Location: EGLM

FS9 troubleshooting with Procmon

Post by jgowing » 28 Nov 2019, 15:23

After a long period of trouble free FS9 operation, I had a new problem: the sim would load but then hang when I got to the main menu page, either with the aircraft preview screen blacked out, or, if that was okay, the sim would hang when I then made any menu selection.

I remembered reading about Procmon, but had never used it. So I gave it a try, and after a while I was able to get an output, with the help of the filter that Steve shared some time ago. Now I have a nice 377 line PML file (or CSV or XML), but I don't know what it means! There are none of the half-expected missing textures or anything like that, and I'm guessing that the mentioned gauge files just relate to the default Cessna appearing in the preview screen.

Would any kind and knowledgeable soul like to take a look and offer an opinion?

Jon G
Attachments
Logfile20191128.zip
(45.6 KiB) Downloaded 6 times

User avatar
hawk_sh
Major
Major
Posts: 797
Joined: 16 Nov 2008, 22:26
Version: FS9
Location: near EDDF

Re: FS9 troubleshooting with Procmon

Post by hawk_sh » 28 Nov 2019, 18:26

While I am not an IT expert I think I remember to have read somewhere that is is not advised to have your FS9 installation under
C:\Program Files (x86)\.
There might be issues with FS9 not having the right to read or write on a certain location (folder).
Access rights to locations/folders might also change when there is a Windows Update.
The term "FILE LOCKED WITH ONLY READERS" is a bit suspicious.

Which operating system?
Was there an update recently.

Maybe try to start FS9 with admin rights?
Hartwig
_______________________________________________________________

Image

jgowing
First Lieutenant
First Lieutenant
Posts: 124
Joined: 08 Oct 2008, 12:36
Version: FS9
Location: EGLM

Re: FS9 troubleshooting with Procmon

Post by jgowing » 28 Nov 2019, 18:42

Hi Hartwig,

Thanks for the quick feedback. You might be right about the x86 folder, although my FS9 has been in there all along and it's been okay until today.

I've had Windows 10 for a while now (3 years or so), and it's been fine, even through numerous updates.

I tried admin rights, but sadly it made no difference.

Jon

jgowing
First Lieutenant
First Lieutenant
Posts: 124
Joined: 08 Oct 2008, 12:36
Version: FS9
Location: EGLM

Re: FS9 troubleshooting with Procmon

Post by jgowing » 29 Nov 2019, 15:58

Mystifying update: Fired up FS9 this afternoon and it was fine, but I had done nothing at all. Hard to believe there's not still an issue lurking, though.

Jon

Post Reply