Creating LOD, questions

The Tutorials forum section is the place where you can learn the various techniques that go into the creation of AI traffic packages.
Post Reply
User avatar
YoYo
Second Lieutenant
Second Lieutenant
Posts: 98
Joined: 27 Feb 2021, 07:55
Version: P3D

Creating LOD, questions

Post by YoYo »

Continuing this topic Id like ask You about creating LODs.

I also read the whole this topic: https://militaryaiworks.com/forums/10/19385 and there are very interesting things here with John's tests. Maybe P3Dv5 (Dx12) also is doing better than P3Dv4.5 (Dx11) because I don't actually see a big difference in FPS with AI models with LOD or without, but I have a very good GPU I have to add it and P3Dv4 and 5 use GPU resources much better than before it was in FS9,FSX and P3Dv1-3.

I learn it on Alphasim C141 about LODs. According this video tutorial, firstly I optimalized textures (option after, I know that it would be best to have it on one card, but it already requires GMAX and changes in the model, I use only MCX):

Image

next I did LOD:

Oryginal

Image

After 3 LODs and removing the first.

Image

Interestingly, with the change from 20k to 13k, the model looks almost the same (with all animations ect), but it is definitely better optimized I think but what I noticed, when I remove the first, oryginal LOD (20k, I dont need it) wheels from the rest LODs models disappeared. What is a cause of it? Does that mean I should separate them earlier and then reconnect them with these inferior LODs?

Second question - how many LOD best to create for P3Dv4/5? I saw examples with 100, 70 and 30 for bigger airplanes and 2 for small.
Webmaster of yoyosims.pl.
Image
User avatar
John Young
MAIW Developer
MAIW Developer
Posts: 3398
Joined: 12 Jul 2008, 15:15

Re: Creating LOD, questions

Post by John Young »

I used to use 7 LODs, now I just use the fully detailed model plus two lower LODs. The intermediate LOD after the full model cuts the polygon count by half and triggers at about half a mile, depending on the user's screen resolution. The final LOD is a paper aeroplane for the far distance.

For wheels, the full model has "slow" and "fast" rotating wheels with bevelled edges to the tyres. The intermediate LOD has non-rotating wheels of just one thickness (no bevelled edges) welded to the gear leg as one part, to save a draw call. The paper aeroplane has no wheels.

If parts like the wheels are disappearing prematurely, the LOD numbering sequence could be wrong or the wheels are not in all the LODs they should be in.

John
User avatar
YoYo
Second Lieutenant
Second Lieutenant
Posts: 98
Joined: 27 Feb 2021, 07:55
Version: P3D

Re: Creating LOD, questions

Post by YoYo »

John Young wrote: 17 May 2021, 11:03 If parts like the wheels are disappearing prematurely, the LOD numbering sequence could be wrong
Thanks, I'm looking for the reason for this, maybe something went missing during the overall conversion, however I dont see any issue in P3D, with animation also and this example what I did:

LOD 100:

Image

From 100 I created 80:

Image

Next removed 100 and in the same time wheels disappear from 80 also.

Image

The name of animation here is c_tire_blurred_key or r or l, so maybe here its an issue?

Creating LOD works, here eg 40:

Image
Webmaster of yoyosims.pl.
Image
User avatar
John Young
MAIW Developer
MAIW Developer
Posts: 3398
Joined: 12 Jul 2008, 15:15

Re: Creating LOD, questions

Post by John Young »

I use:
c_tire_still
c_tire_blurred

Animation is: ​
KF:0 = 0*
KF:50=90*
KF100=180**
KF:75= 270*
KF:100=360*

Same for l and r tires.

I can't help with MCX LOD screens I'm afraid, I use Gmax to create my LODs, but why did you remove LOD100? It should not affect the next LOD in any case, if you have cloned it from the previous one.

John
User avatar
YoYo
Second Lieutenant
Second Lieutenant
Posts: 98
Joined: 27 Feb 2021, 07:55
Version: P3D

Re: Creating LOD, questions

Post by YoYo »

100 is an example (as orginal file, whole model has here 20k triangles, if I did LOD80 with 13k, I removed this 100 and next 80 renamed for 100), I think its ok way?
John Young wrote: 17 May 2021, 17:41 c_tire_still
c_tire_blurred
Is this unstandard entry? I havent it in my own xml, pls see:

Image
Webmaster of yoyosims.pl.
Image
User avatar
John Young
MAIW Developer
MAIW Developer
Posts: 3398
Joined: 12 Jul 2008, 15:15

Re: Creating LOD, questions

Post by John Young »

It's stock xml. You should see it if you open your modeldef file with Notepad and search "c-tire-still".

13k polygons as an intermediate LOD is too high for me, even for a primary LOD. If you can get it down to 5k so much the better, but I don't know how you can do that without re-working the model in Gmax or FSDS.

I'm assuming MCX creates the LODs for you? I can't advise on that as I said. I don't do it that way.

John
User avatar
YoYo
Second Lieutenant
Second Lieutenant
Posts: 98
Joined: 27 Feb 2021, 07:55
Version: P3D

Re: Creating LOD, questions

Post by YoYo »

Yep, I know, I will kept looking for a solution and trying to get what it was because I noticed a problem with wheels also in some other models with new LOD, so maybe something at the conversion stage. If I can solve it, I will come back with an explanation. Thx.
Webmaster of yoyosims.pl.
Image
User avatar
YoYo
Second Lieutenant
Second Lieutenant
Posts: 98
Joined: 27 Feb 2021, 07:55
Version: P3D

Re: Creating LOD, questions

Post by YoYo »

John Young wrote: 17 May 2021, 21:18 It's stock xml. You should see it if you open your modeldef file with Notepad and search "c-tire-still".
Are You sure its a stock? I have stock 3xSDK, for FSX, and v5 and one with modification only for flap, I have only something like this: "l_tire_blurred_key" so with this _key at the end. I havent this:

  • c_tire_still
  • c_tire_blurred
Maybe its your custom settings? If yes, can you share it? I am convinced that it is something with an animation that is hooked up to the highest LOD and will not copy to the next one.
Webmaster of yoyosims.pl.
Image
User avatar
John Young
MAIW Developer
MAIW Developer
Posts: 3398
Joined: 12 Jul 2008, 15:15

Re: Creating LOD, questions

Post by John Young »

In Gmax you can't clone an animation tag - you have to apply the tag each time in the new LOD. I don't know if MCX is the same.

"c_tire_still" is on line 59 of the default P3D modeldef file: P3Dv4 SDK/3ds Max/bin.

John
User avatar
YoYo
Second Lieutenant
Second Lieutenant
Posts: 98
Joined: 27 Feb 2021, 07:55
Version: P3D

Re: Creating LOD, questions

Post by YoYo »

John Young wrote: 18 May 2021, 14:19 "c_tire_still" is on line 59 of the default P3D modeldef file: P3Dv4 SDK/3ds Max/bin.
This line (59) is named "l_tire_blurred_key" in my modeldef, so strange but it looks like its the same.

Btw. I asked on MCX forum... and looks like its a bug in MCX :) :
https://www.fsdeveloper.com/forum/threa ... ost-882545
So maybe this missing wheels in new LOD I'll solve in the next version of MCX, we'll see. Thx.
Webmaster of yoyosims.pl.
Image
User avatar
John Young
MAIW Developer
MAIW Developer
Posts: 3398
Joined: 12 Jul 2008, 15:15

Re: Creating LOD, questions

Post by John Young »

Sorry, my fault. "c_tire_still" is the Fs9 stock part name. "c_tire_still_key" is the xml for FSX and P3D. Just confusing my sims.

If MCX has a bug, how did the Conversion Team here at MAIW get around the problem?

John

PS: Answer - because the LODs were already in the Fs9 model. They didn't need to be created by MCX.
User avatar
YoYo
Second Lieutenant
Second Lieutenant
Posts: 98
Joined: 27 Feb 2021, 07:55
Version: P3D

Re: Creating LOD, questions

Post by YoYo »

Im back with report - its resolved now with Todays update of MCX. It works as it should so I can back to creating some LODs :D .

Image
Webmaster of yoyosims.pl.
Image
User avatar
John Young
MAIW Developer
MAIW Developer
Posts: 3398
Joined: 12 Jul 2008, 15:15

Re: Creating LOD, questions

Post by John Young »

Well done for sticking with it.

John
User avatar
YoYo
Second Lieutenant
Second Lieutenant
Posts: 98
Joined: 27 Feb 2021, 07:55
Version: P3D

Re: Creating LOD, questions

Post by YoYo »

Question from another topic:
John Young wrote: 28 May 2021, 13:38 Always pleased to help. Have you also managed to make the LODs?

John
Yes, I converted it. I did something like this:

Image

I know its not perfect still (decreasing from 20k to 15k, 10k and 8k) but with bigger changes you definitely need to work with GMAX which is beyond my reach (for now ;) ). But it's always "something". Personally I dont see any FPS impact in P3Dv5 (I have about 120-80 fps), maybe here this version of sim handles it better than platforms before?
Webmaster of yoyosims.pl.
Image
User avatar
John Young
MAIW Developer
MAIW Developer
Posts: 3398
Joined: 12 Jul 2008, 15:15

Re: Creating LOD, questions

Post by John Young »

That looks OK LOD-wise. Have you numbered the aircraft individually, or are you just using the one set of textures sharing the same serial number? The latter will help the frame rate rather than loading multiple sets of many textures.

John
User avatar
YoYo
Second Lieutenant
Second Lieutenant
Posts: 98
Joined: 27 Feb 2021, 07:55
Version: P3D

Re: Creating LOD, questions

Post by YoYo »

Correct, just one texture. I saw your post about "groups" of AI fans... I definitely belong to this first group :lol: .
Webmaster of yoyosims.pl.
Image
User avatar
John Young
MAIW Developer
MAIW Developer
Posts: 3398
Joined: 12 Jul 2008, 15:15

Re: Creating LOD, questions

Post by John Young »

That's a sensible move. With 26 textures in the folder, better not to duplicate them multiple times.

Well done for getting there. That learning will pay dividends for future projects I'm sure. Alphasim have a lot you can work with if you are going to continue down that route.

John
User avatar
YoYo
Second Lieutenant
Second Lieutenant
Posts: 98
Joined: 27 Feb 2021, 07:55
Version: P3D

Re: Creating LOD, questions

Post by YoYo »

John Young wrote: 29 May 2021, 15:31 That's a sensible move. With 26 textures in the folder, better not to duplicate them multiple times.

Well done for getting there. That learning will pay dividends for future projects I'm sure. Alphasim have a lot you can work with if you are going to continue down that route.

John
Yep, Thanks John for many of help :).
Webmaster of yoyosims.pl.
Image
Post Reply