NAS Lemoore P3DV4 Package Problem

Share hints and tricks or your own modifications for MAIW Packages in Flight Simulator X and Prepar3D.
Post Reply
jpf813
Second Lieutenant
Second Lieutenant
Posts: 54
Joined: 24 Feb 2018, 18:51
Version: FSX

NAS Lemoore P3DV4 Package Problem

Post by jpf813 » 27 Jan 2019, 16:36

The new NAS lemoore package looks awesome in P3DV4. But I have one problem and no idea how to stop it.

It seems like all the symbols on the hangers flicker like crazy! Any idea what is causing it? and also to reduce it?

Also the writing on the fuel trucks flicker as well.

The main sign that flickers the most is the squadron symbols on the side of the hangers.

User avatar
hschuit
MAIW Conversion Team
MAIW Conversion Team
Posts: 382
Joined: 20 Jul 2011, 07:25
Version: P3D
Location: Near EHSB

Re: NAS Lemoore P3DV4 Package Problem

Post by hschuit » 27 Jan 2019, 17:31

This is the dreaded Z-buffer fighting problem, quite common with converted FS9 scenery objects. FSX and specially P3D do not like rendering scenery object polygons which are placed closely in front of another polygon, in your case the symbol placards. This also happens with FS9 style windows which are modeled as polygons in front of the building wall. The only fix is to remodel those scenery objects.

Henk.

User avatar
petebramley
MAIW Developer
MAIW Developer
Posts: 1132
Joined: 17 Jun 2007, 16:05
Version: P3D
Location: EGBG

Re: NAS Lemoore P3DV4 Package Problem

Post by petebramley » 28 Jan 2019, 08:55

I think Greg has already discovered a way to solve that problem that involved opening the object bgl in MCX and changing a setting. Cannot remember the exact procedure but I’m sure its on the forums somewhere as I did one myself & it worked.
Pete B
Retired and busier than ever !!

User avatar
Firebird
MAIW Admin
MAIW Admin
Posts: 12185
Joined: 11 Aug 2006, 21:04
Version: FS9
Location: EGLL

Re: NAS Lemoore P3DV4 Package Problem

Post by Firebird » 28 Jan 2019, 09:12

Greg wrote about this bug and its fix here :- https://militaryaiworks.com/forums/83/1 ... as#p187757

It seems like it is a fix on a case by case basis so either you have to be patient and wait for somebody to mod a particular library or you could have a go yourself - but I would recommend backing up the lib before attempting such thibgs.
Steve
_______________________________________________________
Image
Quid Si Coelum Ruat
_______________________________________________________

User avatar
hschuit
MAIW Conversion Team
MAIW Conversion Team
Posts: 382
Joined: 20 Jul 2011, 07:25
Version: P3D
Location: Near EHSB

Re: NAS Lemoore P3DV4 Package Problem

Post by hschuit » 28 Jan 2019, 13:53

Thanks to Greg's idea I found this in the P3Dv4.4 SDK:

"In order to improve layering materials on the ground for airport ground polygons, Prepar3D has implemented a Z-Bias level material setting. This functionality only works with "No Z Write" checked on the material. Using values between -1 and -50, you can set and order the layering of the ground polygon textures above the default airport aprons, taxiways and runways. The more negative the Z-bias, the higher layer the material will be. For example, the runway ground polygon could be -1 making it the lower layer, the white runway markings could be the middle layer at -2, the yellow runway markings could be -3 ending as the highest layer. This process can be repeated for up to fifty layers, supporting standard and alpha blended materials."

Summarizing, these would be the object model decal material property values you need to set in MCX:
- Enhanced parameters - No Z Write = true
- Enhanced parameters - No Shadow = true
- Z-Bias = -50

User avatar
Greg
MAIW Admin
MAIW Admin
Posts: 4522
Joined: 12 Aug 2006, 19:56
Version: P3D
Location: Belgium

Re: NAS Lemoore P3DV4 Package Problem

Post by Greg » 28 Jan 2019, 21:03

Indeed you need to give the decal texture a negative z-bias in MCX, but not just any negative value seems to work. I’m traveling for work right now but will provide more details when I’m back.

Post Reply