JYAI KC-10A

Previews, discussions and support for projects by John Young.
User avatar
petebramley
MAIW Developer
MAIW Developer
Posts: 1432
Joined: 17 Jun 2007, 16:05
Version: P3D
Location: EGBG

Re: JYAI KC-10A

Post by petebramley »

I had a couple of crashes at KSUU when I first installed the package. It was during the final 86-99% of the load (AI traffic) so I discounted a scenery problem and started looking at AI textures. Using AIAE I checked every texture that was being loaded at the time. This was all NA Matrix AC and various other military traffic not found in Matrix, with all civilian AI aircraft disabled. I found several textures that were in either BMP format or 32bit dds format. Once all AC had been checked I reloaded with no further problems. Unfortunately I did not make a note of the specific files I changed with “DXTBMP” but I do remember one was an Edwards AFB KC-135. I have found that checking textures with AIAE although a bit time consuming can solve a lot of potential problems.
Pete B
Retired and busier than ever !!
jetpilot1980
Second Lieutenant
Second Lieutenant
Posts: 98
Joined: 04 Oct 2015, 20:17
Version: P3D

Re: JYAI KC-10A

Post by jetpilot1980 »

Interesting what Jim said regarding the quotes and commas... I admit this is the first time I have seen aircraft titles with quotes around them... I may give that a try and see if it helps... It may very well be the commas as I see the 60th are the only aircraft with multiple parking codes and I was not getting any crashes at KWRI with the KC-10s loaded... I will give that a try and report back some time later today... Got to go do friends and family labor day stuff...
User avatar
Firebird
MAIW Admin
MAIW Admin
Posts: 11020
Joined: 11 Aug 2006, 21:04
Version: FS9
Location: EGLL

Re: JYAI KC-10A

Post by Firebird »

As far as I know you have to have commas for the parking or it ignores them.
This was the case with FS9/FSX so I assume it is the same with P3D, I do not know for certain.
Steve
_______________________________________________________
Image
Quid Si Coelum Ruat
_______________________________________________________

Champions of Europe
User avatar
John Young
MAIW Developer
MAIW Developer
Posts: 3501
Joined: 12 Jul 2008, 15:15

Re: JYAI KC-10A

Post by John Young »

Bear with me. I've been out most of the day taking advantage of the change in our weather to wonderful sunshine.

I want to work through this systematically for all 4 sim versions to see which are affected, using the crash time triggers, which are of major help in testing. Because I have near clean installations of all sim versions, I can re-launch to test in just a few minutes each time. The best time for me to do that is early tomorrow morning when the house is quiet and I'm more awake, but I might have a tinker this evening. I knew the package was getting too complicated with so many variables for the 4 sim versions. That just might have led to silly mistakes with commas and inverted commas and potential trouble. Sorry about that.

John
User avatar
John Young
MAIW Developer
MAIW Developer
Posts: 3501
Joined: 12 Jul 2008, 15:15

Re: JYAI KC-10A

Post by John Young »

I’ve done a series of further tests in all 4 sim versions, but I have been unable to find a problem in any sim version (FS9, FSX, P3Dv4.5 and P3Dv5), despite one crash incidence yesterday.

The first test I did was to repeat what I had already done before I released the packages. That was to check to see that all models and textures of a particular aircraft in each squadron appear as they should at my test airfield for each sim version. This involves a simple flight plan that enables all the aircraft to depart at the same time every hour 24/7 and fly one IFR circuit. They do.

Here is a screen shot of all 26 Travis aircraft in P3Dv5. I also have the same result in the other 3 sim versions:

Image

All the aircraft in the shot have aircraft.cfg entries with “” around the aircraft names. I don’t know how I did that, but it may be that in this case, I was working the other way around from what I usually do. Steve created the 3 traffic file components first and it may be that I copied the aircraft.txt entries into the aircraft.cfg file as I was creating it so as to ensure consistency in the names. In doing that, I must have inadvertently included the “” for each aircraft entry. I didn’t notice it though because all the aircraft worked fine in the sims, as you can see from the screen shot.

The next series of tests was to check the 26 60 AMU aircraft at Travis, using the flight plans in the zip. I must have made 30 or so attempts to crash P3Dv4.5 and V.5 at the times reported as problematic. I had no crashes. This is a screen shot of the aircraft at Travis in P3Dv.5 at the time reported for the first crash. It launched fine:

Image

I also found no evidence that the suggestion that parking codes without comma delimitators might have caused a crash, particularly in P3Dv5. They don’t. As Steve (Firebird) says, the worst that might happen is that the parking codes would be ignored and aircraft park in the wrong place. In this case however, for all 4 sim versions, the KC-10’s are in the correct spaces without using comma delimitators.

The final test I did was to check the 60 AMU traffic files. The files (FS9 and FSX/P3D) validate fine in AIFP v3.3.17. I also decompiled the files to the component .txt files to compare the aircraft.txt file to the raw file provided in the zip. They are the same.

The unknown that I can’t cater for is Matrix, OrbX and users with a huge number of aircraft that cause P3D to take 1-2 hours to load. I’m not a Matrix user because I need fairly clean sim versions for fast loading to design with because of the frequency that I need to check things in the sims. The obvious risk with heavily modified installations is the increased chances of a conflict or error.

115 users have downloaded the FSX/P3D KC-10A package, but only 4 have reported a P3Dv5 crash. At least 3 of those users have Matrix. The report of the black polygons in the Travis scenery is indicative of a mismatch or conflict somewhere that I can’t reproduce. The report from Pete that testing other aircraft for errors was also interesting. I don’t know if the correction of the KC-135 textures that led to a crash free Travis launch is illustrative of the potential problem with a Matrix error being confused with a non-Matrix one for the same area, but it has to be likely. The KC-135’s are not in the KC-10A packages. I can’t cater for those potential conflicts without taking on Matrix and Orbx and I clearly don’t want to do that.

I don’t know what else I can do. I have provided screen shots that indicate the integrity of the models, the textures and the Travis scenery. The commas and parking spot delimitators are not an issue and the 60 AMU traffic file appears sound. Some of the 4 users that have reported a problem no longer have it if I have read the posts correctly.

I think I need to park this one unless anything else surfaces.

John
Joseph29
Colonel
Colonel
Posts: 2029
Joined: 20 Sep 2006, 20:35
Version: P3D
Location: Long Island New York

Re: JYAI KC-10A

Post by Joseph29 »

Perhaps the crashes is caused by a different aircraft visiting Travis? I haven't installed the Travis KC-10's yet (going to do it tonight) so I don't know if my sim (P3Dv5) crashes at Travis.

Edit: Or maybe the scenery?
jetpilot1980
Second Lieutenant
Second Lieutenant
Posts: 98
Joined: 04 Oct 2015, 20:17
Version: P3D

Re: JYAI KC-10A

Post by jetpilot1980 »

So on my end I am happy to report trying what Jim said going through the aircraft.cfg and deleting all the quotes around the aircraft titles and then putting commas after each parking code for the Travis aircraft (I left the spaces so it reads atc_parking_codes=KC10, 6ARS, 9ARS) worked! The crashes are gone and KSUU has KC-10s... I am using 4.5 HF3 for what it is worth...
User avatar
John Young
MAIW Developer
MAIW Developer
Posts: 3501
Joined: 12 Jul 2008, 15:15

Re: JYAI KC-10A

Post by John Young »

I don't understand why the commas don't affect my sims, but they apparently do yours, unless there's something intolerant in your P3Dv4.5 HF3 compared to my 4.5.13.32097. Same for the other 111 users who have downloaded the FSX/P3D package and not reported a problem.

Glad it's sorted though.

John
Joseph29
Colonel
Colonel
Posts: 2029
Joined: 20 Sep 2006, 20:35
Version: P3D
Location: Long Island New York

Re: JYAI KC-10A

Post by Joseph29 »

I just installed the Travis KC-10's and I haven't had a crash a Travis yet but I have another question.

Is there a website that says which aircraft belongs to which squadron (6th ARS or 9th ARS)? I looked at scramble.nl but they just say 60th AMW for all aircraft. I ask because wouldn't aircraft from the 6th ARS park with other 6th ARS planes? With both parking codes in the atc_parking_codes= line the squadrons are mixing together.
User avatar
Victory103
Colonel
Colonel
Posts: 3769
Joined: 13 Aug 2007, 03:35
Version: P3D
Location: KPHX

Re: JYAI KC-10A

Post by Victory103 »

I'll add to the few users on P3Dv4.5 HF3 with an issue at Travis. Just catching up on this thread as I was so excited to get the new model in the sim. Running fixes listed above to see what happens.
DUSTOFF
ARMY PROPS
NAVY SAR

-Chris
User avatar
John Young
MAIW Developer
MAIW Developer
Posts: 3501
Joined: 12 Jul 2008, 15:15

Re: JYAI KC-10A

Post by John Young »

I agree that Scramble doesn't separate the Wing into squadron aircraft. I don't know of any other site that might. The aircraft tend to be re-allocated to units frequently, so I'll leave it to users to pursue that level of detail I think.

On the "commas" front, I continue to find no evidence whatsoever that wrapping the aircraft names in the aircraft.cfg file with inverted commas, or spacing parking codes without a comma has any detrimental affect. All of the KC-10 aircraft in the FS9 and FSX/P3D packages are set up that way. If that was not acceptable to the AI engines in all 4 sim versions, no one would be seeing anything. Just as a further test I also wrapped my KC-46A's, that I'm working on at the moment, with inverted comma in the aircraft.cfg names. I also used no commas to separate the parking codes. The 7 aircraft all appeared in the right spots in my AFCAD for KPAE in Seattle in all sim versions.

I really do think that the crashes are caused by something erroneous somewhere in the expanse of Matrix that is impacting the Travis AI catchment area. It could be the Edwards KC-135 that Pete reported. Although Edwards is about 280nm from Travis and maybe outside the Travis area, the aircraft could be flying towards Travis and entering the area at around the specific times listed to cause the crashes.

However, it's not the convention to wrap aircraft names in the aircraft.cfg file and was only done by an unseen and inconsequential accident. For those who want them without them, plus parking codes with comma separators, I have amended the two files (FS9 and FSX/P3D) and put them in the attached zip. I'll also update the download with these files, but I'll give it a few more days to see how users are getting on with the packages.

John
Attachments
KC-10A aircraft.cfg files - no commas.zip
(13.19 KiB) Downloaded 8 times
paul day
Captain
Captain
Posts: 273
Joined: 10 Dec 2006, 19:49

Re: JYAI KC-10A

Post by paul day »

I'd like to add my twopeneth worth to this discussion. What I did was a two stage approach. First I added the new sceneries with the existing aircraft and everything was fine. Then I replaced the existing KC-10's with the new models and my system crashed when trying to access Travis or McGuire so I narrowed down the problem to the aircraft. There are many people on this forum, much cleverer than me who sorted the problem out and now everything is fine on my FSX setup. I believe I am not the only person of the 111 people who downloaded this package who had a problem, but I can wait for the clever people here to come up with a solution, and provide a beautiful product.

Regards Paul Day.
User avatar
John Young
MAIW Developer
MAIW Developer
Posts: 3501
Joined: 12 Jul 2008, 15:15

Re: JYAI KC-10A

Post by John Young »

Paul, what existing KC-10's are you referring to and are these in FS9 or FSX format? I assume you changed the traffic file to the new one, to reflect the new names when testing with the new aircraft?

What time did the crashes occur with the new aircraft? Only 5 people I think have reported a crash problem and they are all P3D users. If you replace your aircraft,cfg file with the one in the above zip and using the new aircraft of course, do you still get a crash?

Just thinking about P3D in the shower, as you do, could a few people with P3Dv4.5 and Hotfix3 do a little test for me please?

With the aircraft.cfg from the FSX/P3D downloaded zip and the inverted commas in the aircraft titles still intact, go to the McGuire section and add a dummy 3 character parking code to the KC10 one already there, but don't put a comma separator in, ie so it reads for example: KC10 DUM and do that for every McGuire aircraft. Remember to save the file.

Now go to McGuire and tell me what happens please.

If P3D crashes, go back to the aircraft.cfg file and put a comma separator between the McGuire parking codes.

Now go to McGuire and tell me what happens please.

If P3D crashes, go back to the aircraft.cfg file and remove the inverted commas from the McGuire aircraft names.

Test at McGuire again and tell me what happens.

Thanks

John
User avatar
f4nutter
MAIW Developer
MAIW Developer
Posts: 2068
Joined: 01 Nov 2007, 16:00
Version: P3D
Location: EGDC
Contact:

Re: JYAI KC-10A

Post by f4nutter »

hi John

i too had crashes at Travis and thought the file KSUU_ADE9_JS.BGL might be the cause so I recompiled it to read KSUU_ADEP4_JS.BGL
but it still crashed, but adding the new aircraft cfg has fixed the problem Travis is working fine thank you.
Jim
Second Lieutenant
Second Lieutenant
Posts: 52
Joined: 22 Apr 2018, 13:12
Version: P3D
Location: EGPF

Re: JYAI KC-10A

Post by Jim »

Here you go John...

Before following your instructions, I checked McGuire did not crash with my previous changes for Travis >> OK.
John Young wrote: 08 Sep 2021, 07:28 ...could a few people with P3Dv4.5 and Hotfix3 do a little test for me please?

With the aircraft.cfg from the FSX/P3D downloaded zip and the inverted commas in the aircraft titles still intact, go to the McGuire section and add a dummy 3 character parking code to the KC10 one already there, but don't put a comma separator in, ie so it reads for example: KC10 DUM and do that for every McGuire aircraft. Remember to save the file.

Now go to McGuire and tell me what happens please.
>> CRASH (a little after 86% load point)

If P3D crashes, go back to the aircraft.cfg file and put a comma separator between the McGuire parking codes.

Now go to McGuire and tell me what happens please.
>> CRASH (with commas added for McGuire parking, NOT Travis)
>> OK (with commas added for McGuire parking, AND Travis)
>> At this point I went back to your original aircraft.cfg >> CRASH


If P3D crashes, go back to the aircraft.cfg file and remove the inverted commas from the McGuire aircraft names.

Test at McGuire again and tell me what happens.
>> CRASH (with commas added for McGuire parking, NOT Travis. Inverted commas removed from all titles.)

Thanks

John
Some surprises there? Need to repeat in case I made some mistake.


Some caveats for my case...
1. Only tried this once so far. At default start time of 30th May 2017 14:00:00.
2. I have P3Dv4.5, but only HotFix 2.
3. I have split off the retro cfg entries, models and textures (as they're for an alternative set up I have).
4. I have Matrix with lots of updates, other sceneries and lots of AI (incl. AIGAIM). I'll strip this down and repeat.


Jim
User avatar
TimC340
Major
Major
Posts: 608
Joined: 07 Mar 2015, 13:18
Version: P3D
Location: Hadleigh, Suffolk

Re: JYAI KC-10A

Post by TimC340 »

I've only tried the package in P3Dv5, but it's working fine (KC-10 package downloaded three days ago). A slight adjustment to the Travis AFC makes for more prototypically-correct operation (and a lot less endless taxying!); take-offs should be from the centre of the field (ie 3R, 21R) and landings towards the centre (3L, 21L).
User avatar
Garysb
MAIW Developer
MAIW Developer
Posts: 2754
Joined: 11 Aug 2006, 19:33
Version: FSX
Location: Scunthorpe, North Lincolnshire, UK

Re: JYAI KC-10A

Post by Garysb »

Works for me out of the box (FSX)
Appart from the Tanker names that was fixed :)

Gary
I believe that every human has a finite number of heart-beats. I don't intend to waste any of mine running around doing exercises.
Buzz Aldrin (1930 -
User avatar
John Young
MAIW Developer
MAIW Developer
Posts: 3501
Joined: 12 Jul 2008, 15:15

Re: JYAI KC-10A

Post by John Young »

That's an interesting set of results Jim and thanks for doing it. Am I reading this right:

Test 2 - McGuire loaded fine with comma separators in the parking codes and with the inverted commas in the aircraft names?

Test 3 - McGuire crashed with comma separators and inverted comma's removed from the aircraft names? That should be the same as using the new cfg files I posted this morning?. Is that not also the same as the fix you applied yourself prior to the test, with no crash?

That is surprising, particularly in view of Ray's result - thanks Ray also.

While those tests were being done, I took the opportunity to update my P3Dv5.2 with the Hotfix for that version, so I'm bang up to date. I then re-tested at Travis at the reported crash time with the zipped (uncorrected) aircraft.cfg file. Everything was fine, as per Tim's feedback - thanks to you Tim also.

I am not going to update my P3D V4.5 - it would require a 2 hour download and a complete re-install. In fact, once we have bottomed this, I am going to uninstall it and cut my sim versions down to 3 - FS9, FSX and P3Dv5.2 and design for those.

Thanks Gary also. I have no concerns about FSX. All works fine for me too.

John
Jim
Second Lieutenant
Second Lieutenant
Posts: 52
Joined: 22 Apr 2018, 13:12
Version: P3D
Location: EGPF

Re: JYAI KC-10A

Post by Jim »

Cheers John,

Not quite...
John Young wrote: 08 Sep 2021, 11:56 That's an interesting set of results Jim and thanks for doing it. Am I reading this right:

Test 2 - McGuire loaded fine with comma separators in the parking codes and with the inverted commas in the aircraft names?
>> ONLY ok when commas are inserted in Travis codes as well as McGuire for some reason

Test 3 - McGuire crashed with comma separators and inverted comma's removed from the aircraft names? That should be the same as using the new cfg files I posted this morning?. Is that not also the same as the fix you applied yourself prior to the test, with no crash?
>> McGuire did crash if Travis parking did not have commas too :shock:

That is surprising, particularly in view of Ray's result - thanks Ray also.
>> Hopefully someone else can corroborate ...or not.


John

Here's an update on my testing with most of the add-ons cut out:

Turned off scenery add-ons except my added airports for NE Americas and Matrix North America. Within Matrix NS, I've removed all traffic bgl files ex. the KC-10 pack ones. So, starting with my last failing aircraft.cfg file...
>> CRASH (with commas added for McGuire parking, but NOT added to Travis. Inverted commas removed from all titles.)

Next, turn off all my NA scenery ex. McGuire...
>> CRASH

Next, switch back to previously working aircraft.cfg with commas for both Travis & McGuire (but inverted commas/quotes still on titles)...
>> OK

So reducing my add-ons has so far not made a difference. (At least I can load quicker.)


In summary for me...


KC10,6ARS,9ARS AND KC10 >> KWRI OK

KC10,6ARS,9ARS AND KC10 DUM >> KWRI CRASH

KC10,6ARS,9ARS AND KC10,DUM >> KWRI OK

KC10 6ARS 9ARS AND KC10,DUM >> KWRI CRASH


Plus, inverted commas round the titles have not made a difference either way for me so far.


Jim
Jim
Second Lieutenant
Second Lieutenant
Posts: 52
Joined: 22 Apr 2018, 13:12
Version: P3D
Location: EGPF

Re: JYAI KC-10A

Post by Jim »

One more...

KC10 6ARS 9ARS AND KC10 >> KWRI CRASH (i.e. no commas, no dummy)

This is contrary to what I said the other day when KWRI seemed OK. However, today I have been using the 2017 default start time.

I repeated starting up at 5th Sep 2021 18:58:06 for KWRI and it was OK as before.
(Then without coming out the sim, I picked a new scenario of KSUU for 5th Sep 2021 18:58:06 and it crashed as before.)

So start time does make a difference as well as lack commas for me.

Jim
Post Reply