North America

Post all questions and problems with Matrix in this forum.
KC10Pilot
Second Lieutenant
Second Lieutenant
Posts: 11
Joined: 13 Aug 2009, 20:53

Re: North America

Post by KC10Pilot »

I have version 1.4.0 and can see two updates for North America but the same problem persists of not being able to update. It keeps saying my internet connection is offline which it isn't.

User avatar
Greg
MAIW Admin
MAIW Admin
Posts: 3752
Joined: 12 Aug 2006, 19:56
Version: P3D
Location: Belgium

Re: North America

Post by Greg »

It sounds like the region version wasn't saved properly in the user config file after installing North America. This can happen if Matrix isn't closed properly after a region installation.

Open Windows Explorer and go to the following folder: %localappdata%\Military_AI_Works. In it should be a folder called "Matrix.exe_andaverylonghash", containing the subfolder "1.4.0.0" and in that subfolder the file "user.config".

Open the file with Notepad or another text file editor and look for the section <setting name="versionRegionNA" serializeAs="String">. It's value is probably still set to 0. Change the value to 1.0, save and close the file. Then restart Matrix.

KC10Pilot
Second Lieutenant
Second Lieutenant
Posts: 11
Joined: 13 Aug 2009, 20:53

Re: North America

Post by KC10Pilot »

Actually, this is interesting. Here's the code:

<setting name="versionRegionNA" serializeAs="String">
<value />

I'll change it to 1.0 using the preceding nomenclature and see what happens.

KC10Pilot
Second Lieutenant
Second Lieutenant
Posts: 11
Joined: 13 Aug 2009, 20:53

Re: North America

Post by KC10Pilot »

Worked like a champ. Thanks for the help Greg!

Post Reply