No highspeed prop visible on MAIW Helos

Post all questions and problems with Matrix in this forum.
KC10Pilot
Second Lieutenant
Second Lieutenant
Posts: 11
Joined: 13 Aug 2009, 20:53

No highspeed prop visible on MAIW Helos

Post by KC10Pilot » 26 Aug 2019, 13:51

Forgive me if I'm posting this incorrectly or asking for help where it was clearly posted before, please. However, I've noticed on the recently released helo's in Matrix for P3Dv4, there aren't any highspeed props/rotors for the Blackhawks, Chinooks, or Apaches. While they're off, the blades are definitely there but once the AI start their thing, there isn't a highspeed "blur" like we would normally see. Is this just because they've been converted and won't convert, the textures aren't there on purpose, or something else? Just curious. Thanks for the help!

User avatar
hschuit
MAIW Conversion Team
MAIW Conversion Team
Posts: 351
Joined: 20 Jul 2011, 07:25
Version: P3D
Location: Near EHSB

Re: No highspeed prop visible on MAIW Helos

Post by hschuit » 26 Aug 2019, 15:26

Strange, I do not have the types you mentioned installed but if a native FSX/P3D helo model has the correct slow and blurred propdisks they should display like in the attached screenshot. This is the Elvis AI Seaking conversion I am working on in P3Dv4.5, right after takeoff when the AI runs at 100% throttle:
Attachments
CJAI_SKing.jpg

User avatar
gsnde
MAIW Staff
MAIW Staff
Posts: 3356
Joined: 05 Apr 2007, 08:13
Version: P3D
Location: South-West Germany
Contact:

Re: No highspeed prop visible on MAIW Helos

Post by gsnde » 26 Aug 2019, 15:37

Please have a look at the pictures of the full release packages for the Apache & Chinook (taken in P3Dv4) - you don't see the rotor like this?

Image

Image
Cheers,
Martin
________________________________________
ImageThe Owl's Nest * Military Aircraft Reference * ICAO Reference * Distance Calculator * MAIW, Military AI & UKMil Reference

KC10Pilot
Second Lieutenant
Second Lieutenant
Posts: 11
Joined: 13 Aug 2009, 20:53

Re: No highspeed prop visible on MAIW Helos

Post by KC10Pilot » 27 Aug 2019, 11:35

No, I sure don't. As soon as the helicopter starts up, it's as if nothing is there. I can see the rotor rotating around but that's it. I've looked in the individual texture folders and didn't see any textures other than the paint file itself. Not that that's indicative I understand but it was the first place I went to look for a texture that could be construed as missing.

Any ideas?

Joseph29
Colonel
Colonel
Posts: 2035
Joined: 20 Sep 2006, 20:35
Version: P3D
Location: Long Island New York

Re: No highspeed prop visible on MAIW Helos

Post by Joseph29 » 27 Aug 2019, 12:22

It sounds like you don't have the rotor textures installed.

KC10Pilot
Second Lieutenant
Second Lieutenant
Posts: 11
Joined: 13 Aug 2009, 20:53

Re: No highspeed prop visible on MAIW Helos

Post by KC10Pilot » 27 Aug 2019, 12:38

Agreed. I used Matrix so I assumed they would have been installed automatically but perhaps that isn't the case. I'm guessing it's just one single texture I'm missing per texture folder which would be easy enough to install myself. Would someone mind sending the prop textures to me for the blackhawks, chinooks, and apaches please? If this is indeed the issue...

User avatar
Greg
MAIW Admin
MAIW Admin
Posts: 4437
Joined: 12 Aug 2006, 19:56
Version: P3D
Location: Belgium

Re: No highspeed prop visible on MAIW Helos

Post by Greg » 27 Aug 2019, 16:55

Moved to Matrix support.

Can you confirm it's the same issue as this: https://militaryaiworks.com/forums/83/18457?

Can you confirm your global libraries in Matrix are updated to version 3.8?

User avatar
Victory103
Colonel
Colonel
Posts: 3521
Joined: 13 Aug 2007, 03:35
Version: P3D
Location: KPHX

Re: No highspeed prop visible on MAIW Helos

Post by Victory103 » 27 Aug 2019, 23:14

Confirmed on my set up and related to my post, covering AH-64 and CH-47. Version Global Textures 3.8 installed, files are there with dates:
NBAI Apache rotors-12/4/2018 86kb dds
NBAI Chinook Rotors- 10/27/2014 86kb dds
DUSTOFF
ARMY PROPS

-Chris

KC10Pilot
Second Lieutenant
Second Lieutenant
Posts: 11
Joined: 13 Aug 2009, 20:53

Re: No highspeed prop visible on MAIW Helos

Post by KC10Pilot » 27 Aug 2019, 23:42

Thanks for the help thus far! I hadn't updated my libraries completely like I had thought so that brought SOME textures in. However, Greg, what I'm seeing seems to mimic what the link in your response shows. I have blades now but they're clunky looking. Not what I would expect.

User avatar
Greg
MAIW Admin
MAIW Admin
Posts: 4437
Joined: 12 Aug 2006, 19:56
Version: P3D
Location: Belgium

Re: No highspeed prop visible on MAIW Helos

Post by Greg » 28 Aug 2019, 08:52

Glad your issue is solved.

I must admit that the prop disk is a bit "clunky" but that's how it was designed. I'll check with Gavin if we can perhaps create an alternative texture that is more in line with our other helicopters.

This still doesn't solve Chris' issue, but at least it confirms that it is working as intended for everyone else.

User avatar
hschuit
MAIW Conversion Team
MAIW Conversion Team
Posts: 351
Joined: 20 Jul 2011, 07:25
Version: P3D
Location: Near EHSB

Re: No highspeed prop visible on MAIW Helos

Post by hschuit » 28 Aug 2019, 09:10

I think the issue is the FS9 prop disk alpha. I saw the "clunky" appearance too when converting the Seaking. I updated the prop disk alpha to make it look smoother/more transparent in FSX/P3D.

User avatar
Greg
MAIW Admin
MAIW Admin
Posts: 4437
Joined: 12 Aug 2006, 19:56
Version: P3D
Location: Belgium

Re: No highspeed prop visible on MAIW Helos

Post by Greg » 28 Aug 2019, 09:20

Henk could you upload your alpha to my share folder please? Your Seaking prop does look pretty good indeed in the screenshot above.

User avatar
hschuit
MAIW Conversion Team
MAIW Conversion Team
Posts: 351
Joined: 20 Jul 2011, 07:25
Version: P3D
Location: Near EHSB

Re: No highspeed prop visible on MAIW Helos

Post by hschuit » 28 Aug 2019, 09:32

Greg, my Seaking FSX prop alpha bmp files are uploaded. Be aware you can't use these for all eggbeaters - the Seaking has a 5-blade rotor/tailprop. For 2-3-4 blades you need a different alpha.

User avatar
Greg
MAIW Admin
MAIW Admin
Posts: 4437
Joined: 12 Aug 2006, 19:56
Version: P3D
Location: Belgium

Re: No highspeed prop visible on MAIW Helos

Post by Greg » 28 Aug 2019, 11:41

Thanks. It's just to have an idea how you did it.

User avatar
Greg
MAIW Admin
MAIW Admin
Posts: 4437
Joined: 12 Aug 2006, 19:56
Version: P3D
Location: Belgium

Re: No highspeed prop visible on MAIW Helos

Post by Greg » 08 Sep 2019, 18:40

Place the 3 textures in the attached zip in your "\MAIW_GLOBAL\MAIW_GLOBAL_TEXTURES" folder and let me know how it looks.

A gradient was added to make the blades more transparent towards the tips and the prop disk on the Apaches was removed by making the space in between the blades fully black on the alpha channel.

If you like it, I'll add the textures to the next update of the Global Libraries package.
Attachments
matrix_replacement_rotors.zip
(49.29 KiB) Downloaded 13 times

User avatar
gsnde
MAIW Staff
MAIW Staff
Posts: 3356
Joined: 05 Apr 2007, 08:13
Version: P3D
Location: South-West Germany
Contact:

Re: No highspeed prop visible on MAIW Helos

Post by gsnde » 10 Sep 2019, 20:31

Has anybody already tested this and can give a feedback?
Cheers,
Martin
________________________________________
ImageThe Owl's Nest * Military Aircraft Reference * ICAO Reference * Distance Calculator * MAIW, Military AI & UKMil Reference

User avatar
petebramley
MAIW Developer
MAIW Developer
Posts: 1114
Joined: 17 Jun 2007, 16:05
Version: P3D
Location: EGBG

Re: No highspeed prop visible on MAIW Helos

Post by petebramley » 11 Sep 2019, 07:01

Missed this one, looking now !!
Pete B
Retired and busier than ever !!

User avatar
petebramley
MAIW Developer
MAIW Developer
Posts: 1114
Joined: 17 Jun 2007, 16:05
Version: P3D
Location: EGBG

Re: No highspeed prop visible on MAIW Helos

Post by petebramley » 11 Sep 2019, 08:05

Both CH47 AND AH64 viewed during taxi and flight and the rotors are much improved.
Pete B
Retired and busier than ever !!

User avatar
gsnde
MAIW Staff
MAIW Staff
Posts: 3356
Joined: 05 Apr 2007, 08:13
Version: P3D
Location: South-West Germany
Contact:

Re: No highspeed prop visible on MAIW Helos

Post by gsnde » 11 Sep 2019, 11:45

Many thanks, Pete!

From mobile hence short

Cheers,
Martin
________________________________________
ImageThe Owl's Nest * Military Aircraft Reference * ICAO Reference * Distance Calculator * MAIW, Military AI & UKMil Reference

User avatar
gsnde
MAIW Staff
MAIW Staff
Posts: 3356
Joined: 05 Apr 2007, 08:13
Version: P3D
Location: South-West Germany
Contact:

Re: No highspeed prop visible on MAIW Helos

Post by gsnde » 15 Sep 2019, 07:20

Jeez, they are improved!

Great job done, Greg. I will show some pictures later.
Cheers,
Martin
________________________________________
ImageThe Owl's Nest * Military Aircraft Reference * ICAO Reference * Distance Calculator * MAIW, Military AI & UKMil Reference

Post Reply