P3Dv4.5 crash on startup

Use this forum to discuss technical issues related to the operation of your computer. Graphics, Hardward, Software, settings, etc.
Post Reply
User avatar
Jim
First Lieutenant
First Lieutenant
Posts: 143
Joined: 22 Apr 2018, 13:12
Version: P3D
Location: EGPF

P3Dv4.5 crash on startup

Post by Jim »

I wonder if anyone can help please, I've been struggling with this for a few days as you might surmise from the long story...

I've been on P3D v4.5 for a couple of years now on a Windows7 pro PC. The sim now crashes on startup consistently after about 4 minutes. That is to say, BEFORE the aircraft/airport/settings menu comes up.

Coincidence probably, but I had been adding some AI, flight plans and a couple of simple sceneries after "jon's paints" led me to Bellini1202's flight plans on aitraffic.ch.

So I thought something I'd installed had upset the sim, but disabling all my add-on packages, the add-on scenery folders, uninstalling AIGAIM and even hiding AI away did not help.

Next I suspected some corruption in the sim software, so braved a re-install, and in fact bit the bullet and went from Hotfix2 to Hotfix3 version 4.5.14.34698 I'd been sat on for a long time.

No improvement, but at that point I noticed some common messages in both their Problem Signatures generated beneath the "Prepar3D exe has stopped working" crash screen, such as:
Fault Module Name: ucrtbase.DLL
Fault Module Version: 10.0.14393.2990
Fault Module Timestamp: 5caeb96f
Exception Code: 40000015

The P3D forum had folk with ucrtbase.DLL crashing mid-flight with version5.1 on Win10. Their fix was to disable SODE or add "AdaptiveSimGroupEnable=False" to [SIM] section of Prepar3D.cfg until SODE got an update for v5/5.1 I think. Anyway, neither worked for me.

On the web, ucrtbase.DLL problems crop up in many circumstances, but one suggestion was to run "sfc /scannow" from the command prompt, but that found no errors with my system files.

I also ran a full Norton anti-virus scan (which only found a low-risk issue) and updated two apps they prompted (Notepad++ and Google Earth pro). No improvement.

I thought I might next try a system restore, but unfortunately my above efforts had overwritten any restore point before the problem started :roll:

Turns out I was starting to come down with covid after getting out and enjoying real life, so I only vaguely know the time the problem arose, but my Control Panel showed Microsoft Edge being installed around that time. Dunno how it got there, but I've uninstalled that too, but to no effect.

I'm knackerred now! Thanks for reading.
Jim
User avatar
TimC340
Lieutenant Colonel
Lieutenant Colonel
Posts: 998
Joined: 07 Mar 2015, 13:18
Version: P3D
Location: Hadleigh, Suffolk

Re: P3Dv4.5 crash on startup

Post by TimC340 »

A search reveals many people have had this problem, and there are many possible fixes. It would appear to be an incompatibility between certain addons and your specific Windows installation. P3Dv5.1 is the most-reported victim.

I would think you’re going to struggle to find new answers for a Windows 7/P3D4.5 installation. I suspect it will be a case of trawling through the hundreds of posts online until you find a fix, or doing a full reinstall.
User avatar
Firebird
MAIW Admin
MAIW Admin
Posts: 11650
Joined: 11 Aug 2006, 21:04
Version: FS9
Location: EGLL

Re: P3Dv4.5 crash on startup

Post by Firebird »

So Jim,
You have tried a complete re-install and ran it w/o addons and it still fails, is that correct?

If so, then following on from what Tim says it sounds like an incompatibility with either a third party add-on or with the OS itself. I don't suspect the OS, as it is 7, UNLESS there was a security update just before you started getting issues.
Steve
_______________________________________________________
Image
Quid Si Coelum Ruat
_______________________________________________________
User avatar
Jim
First Lieutenant
First Lieutenant
Posts: 143
Joined: 22 Apr 2018, 13:12
Version: P3D
Location: EGPF

Re: P3Dv4.5 crash on startup

Post by Jim »

Thanks Tim, Steve,

My re-install was a lot untidier than I summarised. Skip to *** if bored
With all add-ons disabled via P3DAddonOrganizer (ex. flyable add-on aircraft that hadn't changed in ages), I firstly did an update to HF3, reboot, restart.

It crashed again, but noticed the Problem Signature was still reporting App.Ver. 4.5.13.32097 which is HF2. Control Panel showed the Scenery component was still that version so I uninstalled Client & Scenery (I think with the repair option).
I screwed up the re-install, forgetting to direct it to the correct drive. So undid and installed again. Hence no restore points left!

Crashes now report App.Ver. 4.5.14.34698 HF3 correctly though Control Panel still shows the old version number against the Scenery component (perhaps untouched by HF3) :?:


***

I can try a full uninstall (including manual deletion of files & local folders) re-install from scratch with ALL add-ons disabled.


My initial focus was on what changed between working on the 11th (probably 12th) and not on the 13th.
Question: Is disabling the add-ons enough? I remember FSX used to look for all your AI whether it was enabled or not. Does P3D still do that? This is why I hid (i.e. moved SimObject folders off-disk) earlier, but they are back in place now (and time-to-crash didn't change).

Security Updates: There were loads for MS Office on the 9th! I usually shut down each night, but know it was kept on at least one night as I had work-in-progress from aitraffic.ch. 2 or 3 nights I doubt, but worth an un-do perhaps.

Thanks again,
Jim
User avatar
Firebird
MAIW Admin
MAIW Admin
Posts: 11650
Joined: 11 Aug 2006, 21:04
Version: FS9
Location: EGLL

Re: P3Dv4.5 crash on startup

Post by Firebird »

I would like to think that Office updates did not cause the issue but I couldn't categorically clear them.

My first choice would be to clear everything out and reinstall from scratch and add the hotfixes and then see if it runs OK. If it does then add back the addons.
My understanding is that you do not need to uninstall any xml addons. Only addons that integrate fully with the base package.

On the question of whether disabling the addons is good enough I can't say. Logically it should be. They may still look for folders listed but why would you look inside or try to load anything.

If you have nothing that has integrated into the base installation it could be as simple as copying the addon xml file to a safe location and then uninstalling.
Once it has been reinstalled and patched, and proved stable, then a simple case of copying back the saved addon xml over the top of the cleam one would reinstall all of the addons.

Allied to what Tim said the biggest obstacle you will have to clear this issue and others is that you are on 7. I know people like 7 but it may be time to plan for an 11 compatible PC.
Steve
_______________________________________________________
Image
Quid Si Coelum Ruat
_______________________________________________________
User avatar
Jim
First Lieutenant
First Lieutenant
Posts: 143
Joined: 22 Apr 2018, 13:12
Version: P3D
Location: EGPF

Re: P3Dv4.5 crash on startup

Post by Jim »

Whew!
Got my re- re-installed sim to start up.

This time I also uninstalled my user folders with their cfg files. So on start-up, I was prompted whether I wanted to enable each of my regional addon.xml packages, one by one.
I said NO to each for now, but when it got to "South America", it crashed. I removed the SA content from its xml, leaving just the header and re-started OK.

So I knew something in that region was the culprit even while disabled. It took some time, but eventually found that a conversion from FS9 for one airport (SPLP) was the problem. It crashed if both warehouse_airplanes_commercial_prop & warehouse_airplanes_military object libraries were enabled, so I have removed the former.

I've got some more re-installing and a lot of tiding up to do now. Still to check whether SPLP and all other scenery works.

Thanks for the help,
Jim
User avatar
Firebird
MAIW Admin
MAIW Admin
Posts: 11650
Joined: 11 Aug 2006, 21:04
Version: FS9
Location: EGLL

Re: P3Dv4.5 crash on startup

Post by Firebird »

Well done on the diags. Some times it can be time consuming but sometimes there is just no other way of doing it.

Of course the question I would ask now is when did you install SPLP? It would be annoying if you remembered that it was the day before the problem first happened. If it was some time ago then I would say that one of the libs got corrupted.
Steve
_______________________________________________________
Image
Quid Si Coelum Ruat
_______________________________________________________
User avatar
Jim
First Lieutenant
First Lieutenant
Posts: 143
Joined: 22 Apr 2018, 13:12
Version: P3D
Location: EGPF

Re: P3Dv4.5 crash on startup

Post by Jim »

Oh, it was recent, and I'm annoyed Steve :lol:

After the updates, I think I had to drop it and go do other stuff. Out enjoying myself, but was coming down with covid by the time I got back to the sim. By the time it crashed, I'd forgotten what I'd previously changed and apparently not checked.

I guess I was not thinking too well.
Jim
User avatar
Firebird
MAIW Admin
MAIW Admin
Posts: 11650
Joined: 11 Aug 2006, 21:04
Version: FS9
Location: EGLL

Re: P3Dv4.5 crash on startup

Post by Firebird »

JIm, it happens to us all.
Every so called expert has done a similar thing. What makes people experts is not that they don't make those mistakes it is that they learn from them.
Steve
_______________________________________________________
Image
Quid Si Coelum Ruat
_______________________________________________________
Post Reply