WAH-64 rotor texture issues

Post all questions and problems with Matrix in this forum.
Post Reply
User avatar
Victory103
Colonel
Colonel
Posts: 3560
Joined: 13 Aug 2007, 03:35
Version: P3D
Location: KPHX

WAH-64 rotor texture issues

Post by Victory103 »

Test with WAH-64 in UK, although rotor main/tail .dds textures are in the Matrix Global Texture folder, no rotor textures appear in sim or the alpha is off.
DUSTOFF
ARMY PROPS

-Chris

User avatar
Greg
MAIW Admin
MAIW Admin
Posts: 3740
Joined: 12 Aug 2006, 19:56
Version: P3D
Location: Belgium

Re: MAIW NBAI Boeing AH-46 Apache Conversion Support

Post by Greg »

Are these WAH-64 from Matrix Europe or installed manually from the conversion package in subject?

User avatar
Victory103
Colonel
Colonel
Posts: 3560
Joined: 13 Aug 2007, 03:35
Version: P3D
Location: KPHX

Re: MAIW NBAI Boeing AH-46 Apache Conversion Support

Post by Victory103 »

Greg,
Installed via latest Europe Region update, I have not tested/viewed the previously released Asia Region -64s for JGSDF.
DUSTOFF
ARMY PROPS

-Chris

User avatar
Greg
MAIW Admin
MAIW Admin
Posts: 3740
Joined: 12 Aug 2006, 19:56
Version: P3D
Location: Belgium

Re: WAH-64 rotor texture issues

Post by Greg »

Okay, I moved this to Matrix support because I don't think it's an issue in the standalone conversion package.

I'll pay Wattisham a visit and see what's going on.

User avatar
Greg
MAIW Admin
MAIW Admin
Posts: 3740
Joined: 12 Aug 2006, 19:56
Version: P3D
Location: Belgium

Re: WAH-64 rotor texture issues

Post by Greg »

This is what I see.

Image

But it could be a wrong update compilation from my part of course. Could anyone else with the latest versions of Europe and the Global Libraries report what they get for the WAH-64's?

User avatar
petebramley
MAIW Developer
MAIW Developer
Posts: 1137
Joined: 17 Jun 2007, 16:05
Version: P3D
Location: EGBG

Re: WAH-64 rotor texture issues

Post by petebramley »

Greg

I installed MATRIX from scratch this afternoon on my spare PC (Loading only Global and Europe) went to Wattisham and all looked fine.
Pete B
Retired and busier than ever !!

User avatar
Victory103
Colonel
Colonel
Posts: 3560
Joined: 13 Aug 2007, 03:35
Version: P3D
Location: KPHX

Re: WAH-64 rotor texture issues

Post by Victory103 »

Thanks for looking at this gents, I was testing at dusk with clouds in the area in P3Dv4.4, which should not matter. I'll get a pic when I'm back at my cpu for comparison.
DUSTOFF
ARMY PROPS

-Chris

User avatar
Greg
MAIW Admin
MAIW Admin
Posts: 3740
Joined: 12 Aug 2006, 19:56
Version: P3D
Location: Belgium

Re: WAH-64 rotor texture issues

Post by Greg »

Chris, can you attach your add-on.xml file for Matrix Global here please (you should find it in your documents folder)?

User avatar
Victory103
Colonel
Colonel
Posts: 3560
Joined: 13 Aug 2007, 03:35
Version: P3D
Location: KPHX

Re: WAH-64 rotor texture issues

Post by Victory103 »

I hope this is the one you needed.
Attachments
add-ons.cfg
(2.53 KiB) Downloaded 8 times
DUSTOFF
ARMY PROPS

-Chris

User avatar
Greg
MAIW Admin
MAIW Admin
Posts: 3740
Joined: 12 Aug 2006, 19:56
Version: P3D
Location: Belgium

Re: WAH-64 rotor texture issues

Post by Greg »

No not the add-ons.cfg, but the add-on.xml ;)

According to your cfg it should be here: D:\highs\Documents\Prepar3D v4 Add-ons\MAIW Global Libraries\add-on.xml

User avatar
Victory103
Colonel
Colonel
Posts: 3560
Joined: 13 Aug 2007, 03:35
Version: P3D
Location: KPHX

Re: WAH-64 rotor texture issues

Post by Victory103 »

Well ooops, should have known when you asked for a .xml extension. I promise I know what I'm doing, haha.
Attachments
addonxml.txt
(1.51 KiB) Downloaded 7 times
DUSTOFF
ARMY PROPS

-Chris

User avatar
Greg
MAIW Admin
MAIW Admin
Posts: 3740
Joined: 12 Aug 2006, 19:56
Version: P3D
Location: Belgium

Re: WAH-64 rotor texture issues

Post by Greg »

Well the good news is that nothings seems to be wrong with the files. The bad news is that it doesn't bring you any closer to a solution.

Honestly I don't know how to help you further. As far as Matrix is concerned, everything looks okay on your machine and so far there are no other reports of missing prop disks (except if the global libraries weren't up-to-date)... I'd suggest doing a scan for the duplicate files somewhere on your system, perhaps there are old versions of the file installed somewhere, but it's just guess work from now on...

User avatar
Victory103
Colonel
Colonel
Posts: 3560
Joined: 13 Aug 2007, 03:35
Version: P3D
Location: KPHX

Re: WAH-64 rotor texture issues

Post by Victory103 »

Thanks Greg for looking, and that was the path I was going next to see if the old texture file got in.
DUSTOFF
ARMY PROPS

-Chris

User avatar
Victory103
Colonel
Colonel
Posts: 3560
Joined: 13 Aug 2007, 03:35
Version: P3D
Location: KPHX

Re: WAH-64 rotor texture issues

Post by Victory103 »

Greg, I know its been a few months and I have confirmed all the MAIW rotor textures are in the proper folder. Last night I noticed I don't have rotors on any MAIW model, to include JYAI AH-1/UH-1 and JYAI F-35s are missing landing gear/weapon textures. Confirmed again all are in the Global Textures and looked over the add-on xml to see the path for Global Textures, but noticed this on the end of the path:
AddOn.Component>
<Category>Texture</Category>
<Path>D:\Program Files (x86)\Military AI Works\Military AI Works\MAIW_GLOBAL\MAIW_GLOBAL_TEXTURES</Path>
<Type>GLOBAL</Type>
DUSTOFF
ARMY PROPS

-Chris

User avatar
Greg
MAIW Admin
MAIW Admin
Posts: 3740
Joined: 12 Aug 2006, 19:56
Version: P3D
Location: Belgium

Re: WAH-64 rotor texture issues

Post by Greg »

I'm sorry you're still having issues, Chris. :(

Is the < also missing in front of AddOn.Component> in the actual add-on.xml file? Because that could be the issue if it is.

Could you upload the entire file so I could check if anything's wrong, please?

User avatar
Victory103
Colonel
Colonel
Posts: 3560
Joined: 13 Aug 2007, 03:35
Version: P3D
Location: KPHX

Re: WAH-64 rotor texture issues

Post by Victory103 »

Thanks Greg, more research into how P3D does things as I did not know there are 2 add-on.cfg files, one in C: Program Data\LM\P3dv4 and the the other written to C: Users/AppData/Roaming/. I've looked over the cfg to see the MAIW Global Liberies entry and associated path to the addon.xml located in the other drive, that is the one I posted above, all looks normal and I was not sure if the <type>Global<type> meant anything. After an Matrix update, I am think I see my path is wrong as /Military AI Works/Military AI Works/ could be the issue.
DUSTOFF
ARMY PROPS

-Chris

User avatar
Greg
MAIW Admin
MAIW Admin
Posts: 3740
Joined: 12 Aug 2006, 19:56
Version: P3D
Location: Belgium

Re: WAH-64 rotor texture issues

Post by Greg »

Actually, there are 3 possible locations for add-on.cfg files, but you should never have to modify those manually. P3Dv4 generates them on every startup or they are modified by command line. Don't confuse add-on.cfg files with add-on.xml files.

Matrix doesn't write directly to add-on.cfg files and uses the recommended method by LM, meaning it creates add-on.xml files (also called "add-on packages") in one of the locations that are scanned by P3Dv4 every time it is launched.

So the file that is important to look at is "C:\Users\You\Documents\Prepar3D v4 Add-ons\MAIW Global Libraries\add-on.xml". The paths there should be correct, if not you should definitely correct them. During every start of P3Dv4, these "automatically discovered" xml files are read and an add-on.cfg file is generated.

The <Type>GLOBAL</Type> line is there on purpose, although not strictly required by the SDK.

User avatar
Victory103
Colonel
Colonel
Posts: 3560
Joined: 13 Aug 2007, 03:35
Version: P3D
Location: KPHX

Re: WAH-64 rotor texture issues

Post by Victory103 »

Textures back, for some reason I had 2 locations for the Global libraries, the 2nd created in September was the same Global folder structure, but with no files inside.
DUSTOFF
ARMY PROPS

-Chris

User avatar
Greg
MAIW Admin
MAIW Admin
Posts: 3740
Joined: 12 Aug 2006, 19:56
Version: P3D
Location: Belgium

Re: WAH-64 rotor texture issues

Post by Greg »

Awesome. Glad it's solved!

Post Reply