Newbie ADE question

The Tutorials forum section is the place where you can learn the various techniques that go into the creation of AI traffic packages.
User avatar
TimC340
Major
Major
Posts: 436
Joined: 07 Mar 2015, 13:18
Version: P3D
Location: Hadleigh, Suffolk

Re: Newbie ADE question

Post by TimC340 »

Just to note that the replacement fx file sorted both the crash and the lack of movement.

User avatar
Firebird
MAIW Admin
MAIW Admin
Posts: 10490
Joined: 11 Aug 2006, 21:04
Version: FS9
Location: EGLL

Re: Newbie ADE question

Post by Firebird »

That is excellent news, Tim.

I admit that I didn't think of it in the first place because the only symptoms of a problem with effects had been a proggy crash. It would seem that FSX and P3D do have some resilience to Visual C++ Runtime errors that mean no crash but things just won't work as they should.

We will have to make a note of that.

Now it would be nice to see that the file fixes the problem for Edwin as well.
Steve
_______________________________________________________
Image
Quid Si Coelum Ruat
_______________________________________________________

User avatar
TimC340
Major
Major
Posts: 436
Joined: 07 Mar 2015, 13:18
Version: P3D
Location: Hadleigh, Suffolk

Re: Newbie ADE question

Post by TimC340 »

I’ve been looking at Edwin’s KNMM, and also using the Stinstrom version (FSX conversion from Fly Away Simulation) to try and work out the runway utilisation issues, and it’s very frustrating! 28/10 is now out of use IRL anyway, so it’s easy to take that out. Under normal MSFS logic, the AI should use the nearest runway nearest the wind for take off, and similar for landing. You can try and influence that by closing runways for landing or take off, and by removing start points, but they aren’t hard and fast rules (note FSX/P3D works slightly differently from FS9).

In Edwin’s airport, traffic will operate as expected if the wind favours the 1s, but won’t use the 19s even with maximum wind (36kts) from 190! JS’s version will use 19R for landing and take off, but if the 1s are favoured, AI will disappear rather than taxi, but landing traffic will use 1L. All taxi routes are sound, and the runway link is entirely within the runway (that’s a good trap!).

I suspect there is an issue with this runway configuration (staggered parallel), so I need to find an example where it works as it should and see if I can spot any difference. It probably doesn’t help in the JS case that the airport was derived from the FS9 stock airport (there’s an orphaned ILS which gives it away), and Edwin’s description in the OP suggests he started from the stock airport too. This may be a case where a completely new airport is the better answer.

User avatar
TimC340
Major
Major
Posts: 436
Joined: 07 Mar 2015, 13:18
Version: P3D
Location: Hadleigh, Suffolk

Re: Newbie ADE question

Post by TimC340 »

Well, I couldn't work this out! So I went and asked the question over at FSDev. While I was waiting for an answer, I imported the field into P3Dv4.5 (Hotfix 3). I was working on KMEI, just down the road*, when I noticed that the AI at KMNN appeared to be behaving properly. I went back to FSDev to report my revelation to find that someone had already supplied the answer. It would appear that the inappropriate runway allocation is a hangover from the MS AI/ATC engine which LM fixed in P3Dv4.5 HF2, and it's probably not something that I can sort out for Edwin. I guess it's possible that creating a bunch of crosswind runways between 1L and 1R would convince the sim to treat them as properly parallel, but that's a lot of work that right now I don't really want to take on (I'm not a fan of putting in a lot of work to FSX that won't have any benefit in P3D!).

Incidentally, and for a bit of fun, I noticed that every GA aircraft in the SE USA seemed to be heading for 00M (Thigpen Field). I don't know if they have a festival on there at this time of year, but I'd guess that over 100 aircraft were trying to get in!

Image


*Any painters fancy doing the 135Rs of the 186th ARW and the CH-47Ds of Co B the 111th AR?

User avatar
Victory103
Colonel
Colonel
Posts: 3679
Joined: 13 Aug 2007, 03:35
Version: P3D
Location: KPHX

Re: Newbie ADE question

Post by Victory103 »

@TimC340, good find on the ADE issue as I was about to fire up my 4.5HF2 and see how my KNMM install ran. I've checked all my MGAI KC-135 paints and surprisingly could not find the 186th ARW/153rd ARS. The B/1-111 are using CH-47Fs now, but on that note MS is missing several other units, like the Tupelo ArNG UH-72s and AH-64Ds.
DUSTOFF
ARMY PROPS
NAVY SAR

-Chris

User avatar
TimC340
Major
Major
Posts: 436
Joined: 07 Mar 2015, 13:18
Version: P3D
Location: Hadleigh, Suffolk

Re: Newbie ADE question

Post by TimC340 »

Hi Chris, yes the HF2 fix means that the airfield runs perfectly. Indeed, even so far as VFR circuit traffic will stay on the departure runway while it’s flying touch-and-goes, then change to the arrival runway for the final landing. That keeps it out of the way of IFR arrivals - of which there are a fair few from a variety of Matrix traffic files.

Key Field also has a few Matrix visitors, so it’s been well worth a little modding to allow traffic to work there. I’ve cheated and added a few KC-135Rs and CH-47s (yes, F models, you’re right) to at least let it look more or less correct. I’ll return to this airfield one day and drop in a couple of bespoke buildings like the 186th base hangar. But that’s a bit off-topic...

dummy
Second Lieutenant
Second Lieutenant
Posts: 71
Joined: 11 Jan 2018, 10:38
Version: FSX
Location: near EHKD

Re: Newbie ADE question

Post by dummy »

TimC340 wrote:
23 May 2020, 08:20
This may be a case where a completely new airport is the better answer.
Hi Tim,

with this do you mean start from scratch? So delete everything from the stock airport and then begin from there? Or is there another way to start a new airport?

cheers

Edwin

dummy
Second Lieutenant
Second Lieutenant
Posts: 71
Joined: 11 Jan 2018, 10:38
Version: FSX
Location: near EHKD

Re: Newbie ADE question

Post by dummy »

Hi Guys,

i want to thank you all for your suggestions and help with my problem.
I'm glad it had nothing to do with my modding skills. :)

I'm also glad to have managed to get the ai to use rwy 01R/01L instead of 10/28 all the time.

Best regards,

Edwin

User avatar
TimC340
Major
Major
Posts: 436
Joined: 07 Mar 2015, 13:18
Version: P3D
Location: Hadleigh, Suffolk

Re: Newbie ADE question

Post by TimC340 »

dummy wrote:
25 May 2020, 09:44
TimC340 wrote:
23 May 2020, 08:20
This may be a case where a completely new airport is the better answer.
Hi Tim,

with this do you mean start from scratch? So delete everything from the stock airport and then begin from there? Or is there another way to start a new airport?

cheers

Edwin
Given the issue is with the AI engine in FSX, I'd forget about that option. It's entirely possible to do (despite the warnings you'll get in ADE), but it won't give you any advantage. For the version I made to share on FSDev, I reduced the stock airport to 1R/19L and its ILS and then added everything else from scratch to make sure the taxi routes, nodes and hold points were all under control, but it turns out that was unnecessary!

Post Reply