Military AI Works • Cannot get model viewer to work in AI aicraft editor
Page 1 of 2

Cannot get model viewer to work in AI aicraft editor

Posted: 23 Jan 2019, 20:50
by ltregulate
I have never had any issues with AI Aircraft Editor before, but I recently updated my motherboard and processor keeping my hard drives. I have tired the old install of AI Aircraft editor 3.2.2.0 and it works except my model viewer will not display the aircraft. Same after reinstalling the Ai Aircraft editor. All the other functions of the editor seem normal and it reads the AI aircraft, except when I hit the model view it hangs and freezes the program.

I also tried and checked the "display model view in external form" in the setting tabs, but nothing pops up. Is there something I can check to ascertain why the models are not displayed? I am running P3D 4.4. By the way, the textures tab, fltsim.x tab, general tab and backups tab all work fine. Stumped.

Thanks
Brian S

Re: Cannot get model viewer to work in AI aicraft editor

Posted: 23 Jan 2019, 21:25
by Firebird
I updated AIAE.NET to 3.2.0.0 yesterday but had not checked the viewer. I did and it was perfect as always.

Can you just confirm that you are using the AI-Aircraft Editor.NET which is the only version now supported by Martin, this one also auto-updates and so you should have had an update to v3.2.0.0 in the last 72 hrs.

If so the only reason that I can think of for the viewer not working is that the version of .NET being utilised is not up to date.

What it might be worth doing is having a look at the log to see if there are any errors in it that point to the cause.
The log is accessed by File > Log-files ... and then double clicking on the active one. it will open in your favourite text editor.

Re: Cannot get model viewer to work in AI aicraft editor

Posted: 23 Jan 2019, 23:53
by ltregulate
Yes, AI-Aircraft Editor.NET V.3.2.2.0 I'll look at the log.

Re: Cannot get model viewer to work in AI aicraft editor

Posted: 24 Jan 2019, 00:06
by ltregulate
Okay, not sure what happened but I just download and installed the updated Matrix from MWAI, and then ran the editor as administrator and now it's back to normal. Thanks for your response.

Re: Cannot get model viewer to work in AI aicraft editor

Posted: 24 Jan 2019, 06:41
by Firebird
Well that is weird, because as far as I know there should not be any overlap between Matrix and AIAE.
I checked my system and I don't run AIAE as administrator but then again I run it from my F: disk.

I am glad that it is fixed though.

Re: Cannot get model viewer to work in AI aicraft editor

Posted: 24 Jan 2019, 10:51
by Greg
The Matrix installer verifies if the user has the required .NET version for Matrix and installs it if not, so that could have fixed the issue with AIAE.

Re: Cannot get model viewer to work in AI aicraft editor

Posted: 24 Jan 2019, 20:38
by gsnde
I had to make a new installer, and I fear I forgot to include the .Net check... I will verify that.

Re: Cannot get model viewer to work in AI aicraft editor

Posted: 25 Jan 2019, 05:29
by gsnde
Nope, the .Net check is still in my installer. So that should not be the explanation.

Re: Cannot get model viewer to work in AI aicraft editor

Posted: 09 Feb 2019, 23:28
by ltregulate
Well, the issue is popped up for me yet again after the recent AI aircraft editor updates. Everything works except the model viewer. I'll click on an FAIB A319 for instance, and the background screen within the editor is white, then the timeout spinning circle starts with the mouse, and it just runs without any resolution locking up the program. I have a lot of AI traffic, but that has never been an issue with the editor. I have used the validate feature and have no errors in any of my aircraft, except of a couple that do not have any textures installed (yet). I can view the textures with the texture tab no problem, but model view equals crash. All of the other tabs work without a hitch. Driving me slightly insane. Any suggestions on what to check?

Re: Cannot get model viewer to work in AI aicraft editor

Posted: 10 Feb 2019, 00:54
by gsnde
Does Arnos ModelViewer work on the same models?

Re: Cannot get model viewer to work in AI aicraft editor

Posted: 10 Feb 2019, 00:55
by gsnde
Oh and you say crash - do you send the crash report with your mail?

Re: Cannot get model viewer to work in AI aicraft editor

Posted: 10 Feb 2019, 22:10
by ltregulate
Yes, model converter X works fine, I can see the aircraft and models. Long-time AI guy here, and I have hundreds of AIA, FAIB, FSP etc aircraft and liveries. Where would I find the crash report? It hangs I guess is the best description, the mouse pointer spins and it just thinks and sits there. I can leave it for 15 minutes, nothing happens. When the model viewer was working, worked normally. Can't figure out the issue. When I restart the AI editor, it gives me a message that AIAE has crashed last time. We will now delete the saved AIAE setting. The reason is to avoid pointing to an aircraft that has caused the crash to allow the update check to work.

If it's a specific aircraft that is causing this, I can't see which one it is. Where would the crash report be?

Thanks
Brian

Re: Cannot get model viewer to work in AI aicraft editor

Posted: 11 Feb 2019, 05:39
by gsnde
No, the crash report I am talking about will pop up automatically when the application crashes.

What you see is the watchdog message...

Is this with every aircraft you try? What models are you loading - FS9 or later?

From mobile hence short


Re: Cannot get model viewer to work in AI aicraft editor

Posted: 18 Feb 2019, 23:01
by ltregulate
When I reboot the editor, it starts back on the FAIB A319 IAE model. Does not matter what aircraft I try to view in the model viewer, same problem every time. Reboot and back to the FAIB A319 IAE. Program shows now errors with that aircraft. Almost all of my AI models are P3D/FSX native or have been converted from FS9 to P3Dv4 native.

Re: Cannot get model viewer to work in AI aicraft editor

Posted: 19 Feb 2019, 09:36
by Firebird
The reason that it always starts in the FAIB A219 is that you have the remember last path setting ticked. It will always restart there if it is.

What I do not understand is how come the same component works in MCX and not here!

Where do you have AIAE installed?

Re: Cannot get model viewer to work in AI aicraft editor

Posted: 19 Feb 2019, 10:41
by gsnde
Firebird wrote:
19 Feb 2019, 09:36
The reason that it always starts in the FAIB A219 is that you have the remember last path setting ticked. It will always restart there if it is.

It even remembers this when you have it unticked until the release of 3.3.5 this evening. I had commented parts of the code out and only noticed yesterday evening. Also the restore of the AIAE & external viewer window position will work in dual monitor setups as of this evening.

But that AIAE remembers the last aircraft has nothing to do with its inability to show the models in the viewer. Also I understand that this fails for all aircraft.

While it can take some time to fully load an FS9 aircraft, FSX and P3D models are shown nearly instantly.

You describe it is not crashing but being stuck in a loop either doing nothing or never reaching the end of its task. I have not heard of anything comparable before. What I would try is this:

Completely remove AIAE from Windows Programs & Features.

Then enter %localappdata% in the address bar of your Windows File Explorer. You will see a list of folders in the right pane - scroll down until you see "The_Owls_Nest_Tools" and delete the whole folder.

Afterwards download the latest installer from the MAIW download center and reinstall AIAE - don't install it below "C:\Program Files" or "C:\Program Files (86)"!. Just to be sure select another folder than you have now.

On first start you will see the update notification - please update.

Now.... does it work?

Re: Cannot get model viewer to work in AI aicraft editor

Posted: 19 Feb 2019, 20:45
by ltregulate
Thank you for the replay. I will try that later today.

Re: Cannot get model viewer to work in AI aicraft editor

Posted: 19 Feb 2019, 21:41
by ltregulate
Thank you. That fixed the issue. Back to normal. Appreciate all you do.

Thanks
Brian

Re: Cannot get model viewer to work in AI aicraft editor

Posted: 19 Feb 2019, 23:23
by gsnde
You are very welcome, Brian!

Re: Cannot get model viewer to work in AI aicraft editor

Posted: 20 Feb 2019, 14:13
by Trevytt2004
Ive been watching this thread as I was experiencing some weird behaviours...followed the instruction to fully remove and reinstall and what seems to happen is that if you display an aircraft in the viewer and let it run its animations...if I then choose another aircraft...the fltsimx gen and other tabs seem to update..but the model viewer remains the same and then eventually locks

the only way to get round it is to close program and restart... this is on a laptop running win10 64.

Trev