Error installing 1.2.1

Post all questions and problems with Matrix in this forum.
Post Reply
User avatar
HankyPanky
Second Lieutenant
Second Lieutenant
Posts: 10
Joined: 29 Sep 2006, 18:51
Version: P3D
Location: EDDM

Error installing 1.2.1

Post by HankyPanky » 09 Aug 2018, 07:21

When I try to install the new 1.2.1, I always get the error message: "There was an error creating a temporary file that is needed to complete this installation".

This happens, when
- running the previous version as admin using the build-in updater
- starting the msi setup from the newly downloaded package
- disabling anti-virus and disabling firewall
- cleaning the temp folder and restarting W10
- uninstalling the previous version and trying to newly install.

Any idea?

Thanks a lot in advance.

User avatar
Firebird
MAIW Admin
MAIW Admin
Posts: 11394
Joined: 11 Aug 2006, 21:04
Version: FS9
Location: EGLL

Re: Error installing 1.2.1

Post by Firebird » 09 Aug 2018, 07:38

Where are you creating the temp folder?
Ideally it should be in the root of a drive or a short folder name like 'MAIW'. To avoid long name issues. Also preferably not the C drive.
Steve
_______________________________________________________
Image
Quid Si Coelum Ruat
_______________________________________________________

User avatar
HankyPanky
Second Lieutenant
Second Lieutenant
Posts: 10
Joined: 29 Sep 2006, 18:51
Version: P3D
Location: EDDM

Re: Error installing 1.2.1

Post by HankyPanky » 09 Aug 2018, 08:32

Steve, all my temp folders are redirected to single one sitting at c:\temp.

Matrix is directed to install into c:\program files(x86)\Military AI works\Matrix. I tried as well f:\P3Dv4 Tools\Matrix

User avatar
Firebird
MAIW Admin
MAIW Admin
Posts: 11394
Joined: 11 Aug 2006, 21:04
Version: FS9
Location: EGLL

Re: Error installing 1.2.1

Post by Firebird » 09 Aug 2018, 10:00

Ok in which case I had better let Greg come up with a suggestion.
If you look back on previous problems with
The one thing I would say is that it is never advisable to stuff into c:\program files(x86) if something outside that app is likely to update it, just to avoid permission issues but you seem to have covered that.

looking back on previous issues Greg has asked people to check their %LOCALAPPDATA%\Military_AI_Works folder and see if there's a "Logs" folder with an error log. This might help you but it should definitely help Greg.
Steve
_______________________________________________________
Image
Quid Si Coelum Ruat
_______________________________________________________

User avatar
Greg
MAIW Admin
MAIW Admin
Posts: 3959
Joined: 12 Aug 2006, 19:56
Version: P3D
Location: Belgium

Re: Error installing 1.2.1

Post by Greg » 09 Aug 2018, 10:59

That's Windows Installer error 1336, right?

The bad news is that it's not related to Matrix so there's nothing I can fix directly for you. Nor will anything be logged in the Matrix logs. Chances are you're not able to install anything right now.

The good news is that it's not related to Matrix :wink: but a general msi error. A full temp folder is the most common issue, but it may also be that your Windows Installer files are corrupted. If cleaning out your %temp% folder didn't work, try running a system scan (cmd -> sfc /scannow).

User avatar
HankyPanky
Second Lieutenant
Second Lieutenant
Posts: 10
Joined: 29 Sep 2006, 18:51
Version: P3D
Location: EDDM

Re: Error installing 1.2.1

Post by HankyPanky » 09 Aug 2018, 12:00

Thanks guys, any help or idea are really appreciated ;-)

First, the previous versions of Matrix installed without any problem.

Second, I don't have a %LOCALAPPDATA%\Military_AI_Works folder

Third, as said the previous installation of Matrix was into c:\Program Files. But I tried to install onto a different drive also, with same result...

So I need to wait until this is fixed by MS?

User avatar
Firebird
MAIW Admin
MAIW Admin
Posts: 11394
Joined: 11 Aug 2006, 21:04
Version: FS9
Location: EGLL

Re: Error installing 1.2.1

Post by Firebird » 09 Aug 2018, 12:15

Not quite. You have to fix it.
As Greg said you need to run the command 'sfc /scannow' from the cmd prompt that has Admin privileges.

Basically there is an issue with your OS that is preventing the install. The system file checker checks to see whether all the system files are they same as when they were installed. If not it repairs them.
No harm will be done, except for a reboot afterwards if it does find and fix things.

The other option to try is to do a chkdsk, through the admin cmd again. This command 'chkdsk C: /f' (C: is the drive that you are checking) will check for file errors on startup.

If neither of these works then you will have to trawl through the internet for possible causes and fixes. Most times it ban be done, however an error in my Windows 1803 update means that windows search does not work on my machine despite all of the known fixes.
Roll on Redstone 5, hopefully that will sort it.
Steve
_______________________________________________________
Image
Quid Si Coelum Ruat
_______________________________________________________

User avatar
HankyPanky
Second Lieutenant
Second Lieutenant
Posts: 10
Joined: 29 Sep 2006, 18:51
Version: P3D
Location: EDDM

Re: Error installing 1.2.1

Post by HankyPanky » 09 Aug 2018, 15:39

Prior to run sfc it is recommended to run the DISM with checkhealth and scanhealth. I did all three, before coming here to ask for help.

My system is clean and working, from what DISM and SFC are thinking ;-), as well as all other apps. Sorry to say, but at the moment, the MAIW installer is the only app making some trouble.

In the meantime I worked around the problem booting from an emergency W10 USB stick, and installing this way.

Thanks again for your help!

User avatar
Greg
MAIW Admin
MAIW Admin
Posts: 3959
Joined: 12 Aug 2006, 19:56
Version: P3D
Location: Belgium

Re: Error installing 1.2.1

Post by Greg » 09 Aug 2018, 17:49

We don't make an installer. We package Matrix in msi format. The actual app giving you trouble is Windows Installer since error 1336 is a Windows Installer error code. The fact that you're able to run Windows Installer from another boot partition confirms there's likely to be an issue an issue with your Windows.

When you say Matrix-Setup.msi is the only app (sic) giving you issues, did you try running other msi files to verify?

Anyway, glad you found a workaround. :smt023

User avatar
Firebird
MAIW Admin
MAIW Admin
Posts: 11394
Joined: 11 Aug 2006, 21:04
Version: FS9
Location: EGLL

Re: Error installing 1.2.1

Post by Firebird » 09 Aug 2018, 19:39

I did a check on google for the full error and found a few videos of fixes. One is here https://www.youtube.com/watch?v=foHKXLemWaQ

Basically you need to check that your temp variables are hardcoded rather than using a system variable name.
I checked mine and it used 'C:Users\xxx\AppData\Local\Temp' rather than the suggestion in the video, where xxx is the userid.

Might be worth checking those. If yours includes %APPDATA% that might be it.
Steve
_______________________________________________________
Image
Quid Si Coelum Ruat
_______________________________________________________

User avatar
HankyPanky
Second Lieutenant
Second Lieutenant
Posts: 10
Joined: 29 Sep 2006, 18:51
Version: P3D
Location: EDDM

Re: Error installing 1.2.1

Post by HankyPanky » 09 Aug 2018, 20:25

I'm sorry not to be precise enough, and you are absolutely right, it's not an installer, but an MSI package :smt023, but it's the only package I'm having problems with. I tried two other ones, and they completed successfully.

My TEMP variables are always hard coded via enhanced systemsettings. I don't like those windows "twists".

DISM and SFC don't come up with anything wrong, but I'm sure, somewhere in the deep grounds of W10 is a little green gnome dancing around and clapping his hands :-D.

At the moment it's fine the way it is and I can live with it, even not knowing the exact reasonor a solution.

Thanks friends, for your help and support!

Cheers

User avatar
Firebird
MAIW Admin
MAIW Admin
Posts: 11394
Joined: 11 Aug 2006, 21:04
Version: FS9
Location: EGLL

Re: Error installing 1.2.1

Post by Firebird » 09 Aug 2018, 21:23

Like I said, for me Windows search is screwed due to some deep setting somewhere so i know what you mean.
Steve
_______________________________________________________
Image
Quid Si Coelum Ruat
_______________________________________________________

atla
Cadet
Cadet
Posts: 1
Joined: 21 Jan 2016, 18:23
Version: FSX

Re: Error installing 1.2.1

Post by atla » 18 Sep 2018, 13:39

Hi,
Rob from the NL here.
I have installation problem too.
Installing the newest Matrix in F P3dv add on map or in program files x86 folders gives me always error code 2503.
I tried the tips & trics mentioned above, but doesn't help.
When i try to change the compatibility from the installer, I can not choose anything.
Windows version only mentions "previous windows version".

Tap the adm rights at start up in the same screen is also not possible, it remans grey.

I have W10 in the C drive and P3dv4 in the F.
Never problems with Installing ORBX or any other P3dv4 add-ons.


Any idea on error code 2503?

User avatar
Greg
MAIW Admin
MAIW Admin
Posts: 3959
Joined: 12 Aug 2006, 19:56
Version: P3D
Location: Belgium

Re: Error installing 1.2.1

Post by Greg » 20 Sep 2018, 15:57

Hallo Rob!

Apologies for the delay, but I'm away on a course for work and can't check your problem right now. Give me a couple more days.

Post Reply